Ask Your Question
1

Impress: slide content not shown on notes page [closed]

asked 2013-05-31 17:56:33 +0200

johsmi gravatar image

updated 2016-03-03 11:47:34 +0200

Alex Kemp gravatar image

I am using LibreOffice version 3.6.2.2 (Build ID: 360m1(Build:2)) on an 64 bit Ubuntu computer with Ubuntu 12.10 installed.

I wanted to create notes and print them but for many of my slides, the slide content is simply not shown in the notes page. For other slides, it works fine and there is nothing that is "special" about the slides that are not shown.

Is this a known problem/bug or something that a user can influence? This is rather frustrating and very disappointing as I would like to distribute the slides with the notes printed below.

EDIT: I am attaching another document that shows the same problem: when clicking on "Notes" in the slide view or when printing notes the content of the slide is shown blank: example-notesproblem.odp

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-03 11:48:38.815544

Comments

Is there any chance of attaching example document? Would you mind installing LO 4.0.3 to see if it hasn't been fixed already?

mahfiaz gravatar imagemahfiaz ( 2013-05-31 19:57:07 +0200 )edit

I just tried with LO 4.0.2.2 on a 32 bit Ubuntu 13.04 and exactly the same problem there. Cannot share the document where this originally happened and which has many slides, about 30% of which show up empty in the notes, but I was able to create a small test document from another presentation which I have attached to the original question.

johsmi gravatar imagejohsmi ( 2013-06-01 11:51:29 +0200 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2013-06-01 12:21:24 +0200

johsmi gravatar image

While I still consider this a bug, I found a way to solve the problem:

When I am in the notes view and the notes page does not show the content of the slide, and I click on the little icon in the Layouts pane (in the Tasks view to the right) then the content of the slide magically appears in the notes page. After saving the document, the slide will continue to show up. So all that needs to be done is go through all the notes pages and click on the layout icon.

Odd, but at least a rather easy solution to an odd problem!

edit flag offensive delete link more

Comments

I guess you need to change the note master slide.

murmlgrmpf gravatar imagemurmlgrmpf ( 2014-09-02 16:25:30 +0200 )edit
1

answered 2014-02-12 08:12:21 +0200

xperroni gravatar image

I have stumbled on this same problem, except that for me clicking on the layout icon didn't work. Eventually I decided to bite the bullet, open up the ODP file (which is little more than a ZIP archive with a different extension) and look into the content.xml file's contents for a clue on what the problem was.

Since in my case the first slide was still showing in the Notes view (all others were gone), I located the XML tags for that slide and compared them to the other slides' tags. At last I found that for the visible slide, the <draw:page-thumbnail> tag had the following values:

<draw:page-thumbnail draw:style-name="gr1" draw:layer="layout" svg:width="12.304cm" svg:height="10.393cm" svg:x="4.347cm" svg:y="3.097cm" draw:page-number="1" presentation:class="page"/>

Whereas for the next slide the values were:

<draw:page-thumbnail draw:style-name="gr1" draw:layer="layout" svg:width="0.001cm" svg:height="0.001cm" svg:x="0.991cm" svg:y="3.098cm" draw:page-number="2" presentation:class="page"/>

Did you catch it? The values for svg:width and svg:height were all but zeroed.

From there I found two possible solutions to the problem:

  1. Open the ODP file in Ubuntu's Archive Manager (or any archive manager that can update files within an open archive), open the included content.xml file in a text editor (I had to resort to Okteta, because the file is essentially one looong line and Kate chokes on those), search/replace the bad attribute values, save and let the archive manager update the file;
  2. If you go to the Notes view, click inside the page and hit Tab, a single green square will appear at the left border. This is the slide thumbnail – it is there after all, only set to a very, very small size. Once it's highlighted you can select Format -> Position and Size... in the main menu (it might be blanked out the first time around, so click on the page again, hit Tab and try a second time), deselect the Protect -> Size option and correct the thumbnail's dimensions.

I still have no idea what causes this behavior. For me it happens all the time, even as little as creating a new slide with the first Master Page (meant for the cover slide) instead of the second is enough ... (more)

edit flag offensive delete link more

Comments

PS: I know this is a somewhat old thread, but it's still one of the first results for Google searches on this problem, and I wanted to leave my case documented for whoever else has this same problem.

xperroni gravatar imagexperroni ( 2014-02-12 08:13:12 +0200 )edit
0

answered 2013-06-01 14:25:59 +0200

oweng gravatar image

I think you have somehow managed to get the slide content into a state that the notes preview simply cannot handle. You appear to have used a list style and turned all the list settings off rather than simply use a different layout. That probably explains why selecting a different layout appears to fix the problem.

Here is what the XML of your slide looks like:

<draw:frame>
    <draw:text-box>
        <text:list>
            <text:list-header>
                <text:p>
                    <text:span>Title</text:span>
                    <text:span><text:line-break/></text:span>
                    <text:span>This is my main title page</text:span>
                </text:p>
            </text:list-header>
        </text:list>
    </draw:text-box>
</draw:frame>

Here is what the XML for a Blank Slide layout with two text boxes OR a Title Slide layout with the default areas filled in:

<draw:frame>
    <draw:text-box>
        <text:p>Title</text:p>
    </draw:text-box>
</draw:frame>
<draw:frame>
    <draw:text-box>
        <text:p>This is my main title page</text:p>
    </draw:text-box>
</draw:frame>

It may well still be a bug, but it is a highly specific one.

edit flag offensive delete link more
0

answered 2014-09-02 15:52:49 +0200

I had the same issue with the slides not showing up on the notes page because of beeing tiny small. The proper solution for me was to go to the View/Master/Notes Master menu. Then hit tab to select the slides frame and adjust the size and position to your needs. Voila.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-05-31 17:56:33 +0200

Seen: 7,107 times

Last updated: Sep 02 '14