Ask Your Question
0

librebase - currency field forces prices to zeros

asked 2019-02-25 09:11:01 +0200

studiosboy22 gravatar image

librebase - currency field forces prices to zeros - Is there are way that will keep the "exact currency price."

For example if I put in $51.22, when I tab out to the next field it auto-changes it to $51.00

thanks

edit retag flag offensive close merge delete

Comments

Not familiar with Base - but I'd suspect that your database's field used to store the currency is some kind of integer field. Would possible need your table definition to answer.

Mike Kaganski gravatar imageMike Kaganski ( 2019-02-25 10:19:59 +0200 )edit

Please check the field definition of price. Base has default "0" of decimal digits - so if you did not specify a "2" during table definition, this may cause your observation.

Opaque gravatar imageOpaque ( 2019-02-25 10:25:56 +0200 )edit

Thank you! (solved) - For me I was "only" at the (table definition creation process level) was able to change the decimals where they would "stay with the field" when changing it to a currency field latter on in the field formatting. I had to at the table definition level make a two-decimal "numeric" field (currency field is not an option at that point) when creating the table. Then after I create the table, I can choose "currency" in the field formatting options by converting the table creation defined numeric field (that already has a 2 decimal definition) into a currency field that will retain the two decimals for the currency.

Thank you for the comments, it was a great help!

studiosboy22 gravatar imagestudiosboy22 ( 2019-02-25 20:37:14 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-02-25 10:32:09 +0200

ebot gravatar image

What did you define in your table? E.g.:

image description

What is the currency field? Where is not displayed correctly, Table, query, form or report?

If you've defined it correctly in your table, you can define that also in query, form or report.

edit flag offensive delete link more

Comments

I had to create the decimals "first" in the field creation process by defining a new table. I couldnt get this to work if the field was already created without the two decimals.

This solved my problem :) thank you very much!

studiosboy22 gravatar imagestudiosboy22 ( 2019-02-25 20:42:04 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-02-25 09:11:01 +0200

Seen: 30 times

Last updated: Feb 25