Ask Your Question
0

CTRL+Home not working

asked 2019-03-01 19:08:32 +0200

gazzaro gravatar image

Even if I try to modify the keyboard settings in Tools --> Customise --> Shortcut Keys, I cannot get CTRL+Home to go to the beginning of the document in LO Writer 6.1.5.2 (x64). I have tried assigning other shortcuts, like CTRL+PgUp to "To Beginning of Document", but nothing works. CTRL+Home behaves like this: on first pressing: nothing; on second pressing: goes to end of paragraph!

CPU threads: 8; OS: Windows 10.0; UI render: default; Locale: en-GB (it_IT); Calc: group threaded

Thanks for any hints, bye, Gabriele

edit retag flag offensive close merge delete

Comments

Does it work in other LO modules, for example, Calc?

Does it work in other applications?

BigRAl gravatar imageBigRAl ( 2019-03-02 15:39:58 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2019-03-03 14:05:07 +0200

gazzaro gravatar image

I think the problem is with Sections. I have created a document with sections, and I see that CTRL+Home works like this:

  1. Cursor INSIDE a section: on pressing CTRL+Home ONCE the cursor goes to the beginning of the Section, not the Document (likewise CTRL+End goes to the end of the Section, not the end of the doc).
  2. Cursor INSIDE a section: on pressing CTRL+Home TWICE the cursor goes to the beginning of the Document (likewise CTRL+End TWICE sends the cursor to the end of the doc).
  3. Cursor OUTSIDE a section: on pressing CTRL+Home ONCE (or more) the cursor correctly goes to the beginning of the Document (CTRL+End correctly goes to the end of the doc).
  4. If the document uses Hidden sections, CTRL+Home is erratic, as stated in my original post: on first pressing nothing happens; on second pressing it goes to the end of the paragraph...

It must be a bug...

edit flag offensive delete link more

Comments

It must be a bug...

Well - the #4 in your description ("If the document uses Hidden sections, CTRL+Home is erratic, as stated in my original post: on first pressing nothing happens; on second pressing it goes to the end of the paragraph...") looks indeed like a bug; please file it to bug tracker, along with a sample document to reproduce, and specific steps required (e.g., at which position in your sample a cursor needs to be to see that). Thanks - and great you nailed this down.

Note that there are other cases when Ctrl+Home (expectedly) doesn't bring you to the beginning of the document: e.g., in a table, first Ctrl+Home moves you to start of current cell; second - to the start of the very first cell in this table; and third - to beginning of the document. Nested tables and sections will add to that.

Mike Kaganski gravatar imageMike Kaganski ( 2019-03-03 14:24:04 +0200 )edit
0

answered 2019-03-01 19:56:24 +0200

ebot gravatar image

To the beginning of the document you press CTRL+Pos1

edit flag offensive delete link more

Comments

What is "Pos1" ?

According to the LO Help, Ctrl+Home is 'go to the beginning of the document'.

BigRAl gravatar imageBigRAl ( 2019-03-02 15:34:45 +0200 )edit

Exactly. But it does not always work: I have noticed it works for me in other documents, but not one with sections. That seems to be the problem: having sections. But why should it NOT work if your document has sections?

gazzaro gravatar imagegazzaro ( 2019-03-02 19:20:24 +0200 )edit

Sorry, the thame as "Home".

ebot gravatar imageebot ( 2019-03-03 08:53:58 +0200 )edit

Sorry, the thame as "Home".

Gotcha, thanks.

BigRAl gravatar imageBigRAl ( 2019-03-03 16:37:52 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-01 19:08:32 +0200

Seen: 44 times

Last updated: Mar 03