How to modify Writer's autocorrect behaviour after punctuation? [closed]

asked 2013-06-05 11:25:22 +0200

David gravatar image

updated 2015-10-04 19:12:59 +0200

Alex Kemp gravatar image

I use the "Autocorrect while typing" feature fairly extensively, especially for triggering em-dash and en-dash replacements. However, it seems that a punctuation mark prevents the autocorrect action from triggering. For example:

...here is some text--with an aside!--that would result in...

What I want to happen, is to get this result:

...here is some text—with an aside!—that would result in...

But what I get instead is this:

...here is some text—with an aside!--that would result in...

Note the second (desired!) em-dash is not "autocorrected".

I have looked in the autocorrect options themselves, as well as at the programme's "Tools > Customise..." and "Tools > Options..." settings, but I can find nothing to modify this behaviour. Am I beat? or is there a way of modifying this pattern?

(My current work-around is to leave out the punctuation, keep typing, and return to insert it once the autocorrect has taken place. This is a bit clunky, of course. I'm using LO 4.0.3.3, FWIW.)

Thanks for any help with this!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-04 19:13:08.362354

Comments

1

Related: Automatically place en (not em) dashes between numbers · How to use "AutoCorrect Options → Replace dashes"

"AutoCorrect Options → Replace dashes" seems to be available only for

"text consisting of letters A to z or digits 0 to 9".

manj_k gravatar imagemanj_k ( 2013-06-05 12:21:42 +0200 )edit

Only for "text consisting of letters A to z or digits 0 to 9"? That's a wee shame! Still, there are a couple good work-around possibilities (keyboard shortcuts, for example) should this prove irksome enough. Thanks @manj_k

David gravatar imageDavid ( 2013-06-05 12:33:48 +0200 )edit