Ask Your Question
0

Date format like in Windows

asked 2019-03-13 11:13:03 +0200

uffe_K gravatar image

In Windows I have set short dateformat to be dd-MM-yyyy, but Calc only accepts dd/MM/yyyy as input format when I enter dates. Obviously it is quite annoying that Calc is the only software package in my computer, which ignores my windows settings. Can it be fixed?

I am on 6.1.5.2

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-03-13 11:43:23 +0200

uffe_K gravatar image

OK, adding "D-M-Y" to that list lets me enter the date in my desired format, but it it is still shown as DD/MM/YYYY despite my windows setting is different. If I change the locale from English to Danish, I get it correct, but now my decimal point changes from . to ,

Why can't LibreOffice not simply use the setting which has been defined in windows as a whole and which all other applications use? I'm almost ready to dump it and pay for an MS Office license.

edit flag offensive delete link more

Comments

Please answer in comment, if you do not answer the question but commenting an answer. Please check the format of your cells. This is a different thing than recognizing date values. You can specify hundredth of date formats, which only is the representation of a date / time value. To do so - select your cell, right click to get the context menu and select "Format cells" and define under Category "Date" how you want to see the date.

Opaque gravatar imageOpaque ( 2019-03-13 11:49:38 +0200 )edit

https://ask.libreoffice.org/en/questi...

Wrt "I'm almost ready to dump it and pay for an MS Office license" - if someone finds some application that fits one's needs, be it free or paid, - that's a great thing, and so everybody possibly would be quite happy for that satisfied user.

Mike Kaganski gravatar imageMike Kaganski ( 2019-03-13 11:51:47 +0200 )edit

Why can't LibreOffice not simply use the setting which has been defined in windows as a whole Because there are people, who have a need for some other representation of date values than the one and only defineable in Windows and btw. MS Office products have almost the same "formatting" facility in Excel then the one integrated in LO and which you have complaints about. There is almost no difference.

Opaque gravatar imageOpaque ( 2019-03-13 11:55:15 +0200 )edit

Well - the RFE mentioned in the other question I linked above is a reasonable one: to use OS settings by default, which doesn't disallow whatever special formatting can be applied by using format strings if required. However, it is not implemented (yet). LibreOffice relies on built-in locale defaults, and does not use OS-provided formats.

Mike Kaganski gravatar imageMike Kaganski ( 2019-03-13 12:02:41 +0200 )edit

@Mike Kaganski - I cannot follow the RFE and the requirement.For me a date is a number stored in the application and there is a representation of this number for users readability - that's it for me.

Opaque gravatar imageOpaque ( 2019-03-13 12:25:17 +0200 )edit

The question here was two questions actually: "why application doesn't understand me when I enter dates according to pattern defined in my OS settings", and "why a date I entered into a cell, even after I configured LO to understand me, by default is shown using some format other than set in my OS settings". The "answer" by OP, and the FRE are about the latter.

Mike Kaganski gravatar imageMike Kaganski ( 2019-03-13 12:29:17 +0200 )edit

Basically I want it to behave according to my windows settings, both when entering a date and when displaying the date, without having to do anything special. I didn't know LibreOffice had a specific setting for formats when entering a date, until Opaque replied. Displaying the date still requires setting the format for every cell, it doesn't use the windows setting by default.

uffe_K gravatar imageuffe_K ( 2019-03-13 12:38:51 +0200 )edit

Displaying the date still requires setting the format for every cell

You should only create a cell style with a format you want, and apply it per-column.

it doesn't use the windows setting by default

yes, that's what that other question (and its answer) is about. LibreOffice does not use OS-provided formats, be it number, date, or time.

Mike Kaganski gravatar imageMike Kaganski ( 2019-03-13 12:44:02 +0200 )edit
0

answered 2019-03-13 11:23:02 +0200

Opaque gravatar image

updated 2019-03-13 11:31:07 +0200

Hello,

if you are using english version of LibreOffice your default for "Date acceptance patterns" is "M/D/Y";M/D" (other languages may have different ones). If you want LibreOffice to recognize "dd-MM-yyyy" as a valid date format you need to specifiy in Tools -> Options -> Language Settings -> Languages in field Date acceptance patterns.

image description

edit flag offensive delete link more

Comments

Don't forget that those are English (USA) acceptance patterns. Other languages differ. English (UK) for example is D/M/Y;D/M;D-M. However they use the same internal computer date, in seconds from 1/1/1970 if my memory serves me correctly. As LibreOffice supports the international standard Gregorian, if you are using old dates for calculations in Excel which still has the twenty five year old date bug, you may need to adjust the date setting for the "first day in the 20th century" VIEW > OPTIONS > LIBREOFFICE CALC > CALCULATE.

petermau gravatar imagepetermau ( 2019-03-13 16:48:17 +0200 )edit

Please see what I wrote in parentheses .. "(other languages may have different ones)"

Opaque gravatar imageOpaque ( 2019-03-13 17:54:27 +0200 )edit

I agree (other languages may have different ones) . However, there are a number of versions of English. When I write English I mean in computing terms English (UK) or English(GB). Others, over the other side of the Atlantic mean English(US). The same is true in, for example French or Spanish.

petermau gravatar imagepetermau ( 2019-03-14 13:32:54 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-13 11:13:03 +0200

Seen: 56 times

Last updated: Mar 13