Remove commas from decimal number?

asked 2019-03-16 10:38:44 +0100

Lika gravatar image

updated 2019-03-16 10:42:23 +0100

Have tried searching for answers to the question but oddly I have found nothing. How do I remove a comma completely? For example lets say I have the number 1.5423 and I want it to be 15423 I have tried all different combination in "find and replace" but I can not figure out why it does not work. Find: . Replace with: (did not write anything since I want it to be replaced by nothing)

However this completely removes all entries in cells.

I then tried to as an experiment- Find: . Replace with: , (this is a comma) thinking it would replace the dot with a comma but every single digit was turned to a comma.

What am I doing wrong?

edit retag flag offensive close merge delete

Comments

However this completely removes all entries in cells

That means you have regular expressions enabled: in regular expressions, . is a special character matching any character.

Mike Kaganski gravatar imageMike Kaganski ( 2019-03-16 10:42:02 +0100 )edit

Yes but still without regex it behaves strange. It adds decimals like this 15424.0000. I can then off course delete decimal places and maybe problems solved? Using regex I tried find [.] but got same results as using find and replace without regex.

How can a simple thing like this be so odd? Once again Mike, you saved me again! Damn wish I could donate a buck or two =)

Lika gravatar imageLika ( 2019-03-16 10:59:17 +0100 )edit

You need to check the cell format - which is likely set to show you 4 decimals.

Mike Kaganski gravatar imageMike Kaganski ( 2019-03-16 11:05:06 +0100 )edit