Remove commas from decimal number?

Have tried searching for answers to the question but oddly I have found nothing.
How do I remove a comma completely? For example lets say I have the number 1.5423 and I want it to be 15423
I have tried all different combination in “find and replace” but I can not figure out why it does not work.
Find: .
Replace with: (did not write anything since I want it to be replaced by nothing)

However this completely removes all entries in cells.

I then tried to as an experiment-
Find: .
Replace with: , (this is a comma) thinking it would replace the dot with a comma but every single digit was turned to a comma.

What am I doing wrong?

However this completely removes all entries in cells

That means you have regular expressions enabled: in regular expressions, . is a special character matching any character.

Yes but still without regex it behaves strange. It adds decimals like this 15424.0000. I can then off course delete decimal places and maybe problems solved?
Using regex I tried find [.] but got same results as using find and replace without regex.

How can a simple thing like this be so odd?
Once again Mike, you saved me again! Damn wish I could donate a buck or two =)

You need to check the cell format - which is likely set to show you 4 decimals.