Ask Your Question

Copy visible cells in calc

asked 2019-03-18 10:20:12 +0100

PROXIMO gravatar image

updated 2019-03-21 20:49:24 +0100

Well i see there is a extension for that, but it is not working on version 6. And why should we use extension for something so essential to calc. I think it should be implemented in the newer versions. Until then i would be most grateful if somebody shows me how to do this operation. Thanks!

edit: Sorry i use the latest version on windows 7 64 and i confirm that extension is not working for me, not copying anything i have tried to install it 3 times already i see it in menu but does not copy anything for me. I have tried also second method that you have said and i cant make it work either. i have 2 columns in my sheet with names and numbers i have used sumtotal to have the sums of all equal names and wanted to copy result to another table but i am unable to do so. Result in sheet 2 was only A1 and B1. Please help. image description

edit2: i have tried to lower security for macros and still the addon is not working for me in 6.2.1

edit retag flag offensive close merge delete


Have you set up the configuration to run the macros, Menu/Tools/Options/LibreOffice/Security, if no that, test with Menu/Help/Restart in Safe mode to try with a clean profile.

m.a.riosv gravatar imagem.a.riosv ( 2019-03-20 00:32:08 +0100 )edit

3 Answers

Sort by » oldest newest most voted

answered 2019-03-19 14:06:43 +0100

m.a.riosv gravatar image

First the extension "Copy only visible cells" works fine for me with the latest Version:

Other that you can do is using the standard filter to copy filtered data to other place.

image description

There is an old bug request for that "Copy only visible cells"

edit flag offensive delete link more



that copy technique is what i needed, thanks

MostlyCalc gravatar imageMostlyCalc ( 2020-03-06 22:40:44 +0100 )edit

answered 2020-12-07 00:22:21 +0100

Aaaron gravatar image

The easiest way without having to install anything is to copy the filtered data after filtering it exactly as you want, then when you paste it into another sheet choose "paste special" and select "Skip empty cells" in the bottom left Options, you only have to check it once, it remembers (you still have to paste special every time, but you don't have to re-check the box).

edit flag offensive delete link more

answered 2019-03-19 20:03:48 +0100

PROXIMO gravatar image

updated 2019-03-21 20:47:55 +0100

for deletion...

edit flag offensive delete link more


Please edit your question or use the comments, this is not an answer.

m.a.riosv gravatar imagem.a.riosv ( 2019-03-20 00:30:04 +0100 )edit

You have "Склад" = 1. But on the screenshot, it looks like your "Склад" is a text field - so possibly no rows could satisfy the condition; so only heading is copied. You need to remove the first operator (set Field name to None).

But anyway, the Standard filter would only keep filter criteria, not the manually hidden rows.

Mike Kaganski gravatar imageMike Kaganski ( 2019-03-20 02:02:08 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2019-03-18 10:20:12 +0100

Seen: 4,165 times

Last updated: Dec 07 '20