Ask Your Question
0

Data > Group on Pivot table creates a mirror date column instead of grouping into hours

asked 2019-03-20 17:54:29 +0200

Tobruk gravatar image

updated 2019-03-20 17:55:24 +0200

According to the LibreOffice Manual, after clicking Data > Group, a popup window should appear that allows me to choose how to group a given pivot table.

So, since I wanted to group my pivot table into hour groups based on date column (dd::mm::yyyy hh:mm::ss), I thought I'd use this feature.

However, after clicking Data > Group, Calc merely creates another column with the same data as the original column with dates. (and names it days since starting date2) There is no option to choose how to group the data.

This is my pivot table:

pivot table before using group feature

edit retag flag offensive close merge delete

Comments

Try with dates as column fields, not as row fields

Mike Kaganski gravatar imageMike Kaganski ( 2019-03-20 18:58:00 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-03-20 21:07:35 +0200

updated 2019-03-20 21:23:44 +0200

Hello @Tobruk

Make sure your date column holds actually date/time values, not text string representing date. That is the reason why it is not possible to group Pivot Table results by time periods. When you try to group cells containing text string, Pivot Table just creates same column aside to original one (bug possibly?). Please see this answer with step by step manual on creating Pivot table and grouping result.

---Edit 2019-03-20 22:19---

Added sample file. One sheet contains Pivot Table created from Date/Time values formatted as YYYY-MM-DD HH:MM:SS, other sheet holds identical Pivot Table created from text strings looking exactly the same as YYYY-MM-DD HH:MM:SS Try to group both of them.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-20 17:54:29 +0200

Seen: 23 times

Last updated: Mar 20