Ask Your Question
0

Why doesn't calc parse an imported .CSV file?

asked 2019-03-21 08:16:30 +0200

RCMusall gravatar image
edit retag flag offensive close merge delete

Comments

1

Because it's not a valid CSV?

Mike Kaganski gravatar imageMike Kaganski ( 2019-03-21 08:27:37 +0200 )edit
  1. You are trying to use three separators. This is not normal for a well-structured file. Try each option separately.
  2. Share the file, not a screenshot.
gabix gravatar imagegabix ( 2019-03-21 09:02:55 +0200 )edit

With only comma as separator, and beginning from row 9 not 80, I think it should work.

m.a.riosv gravatar imagem.a.riosv ( 2019-03-21 09:15:06 +0200 )edit

Further to the advice above from @Mike Kaganski, @gabix, and @m.a.riosv, it might help to use a text editor to remove the non-csv "housekeeping" data from your CSV file before trying to import it into Calc.

I do this routinely (4 times each month) while collecting data from an automatic data recording device. Then I open the edited CSV file in Calc and COPY the block of rows and columns of data that I need. Close Calc, then open my current spreadsheet and PASTE the data into its place in the spreadsheet. Done this way, the commas and quotation marks all disappear and the new data is appended to the old data so I can continue with analysis. There might be a better way, but this has worked for me for more than a year.

ve3oat gravatar imageve3oat ( 2019-03-21 23:59:39 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-04-13 23:38:33 +0200

I had the same problem. If I just start Calc & do file > open and name the .csv file, calc produces something very strange. Here is a sample file:

A,B,C

D,E,F

G,H,I

(the extra line spacing is an artefact of the forum software). Calc produces a single cell that looks like this:

"ⱁⱂ੃ⱄⱅ੆ⱇⱈ੉"

Excel reads the same file correctly.

Thank you ve3oat for your reply. When I did what you said: select the text from the .csv file & copy & paste into calc, it gets read correctly.

edit flag offensive delete link more

Comments

1

No, that is not the same problem. This only means that you have selected "Unicode (UTF-16)" character set in Text Import dialog, when you should have selected UTF-8 or some other encoding.

Mike Kaganski gravatar imageMike Kaganski ( 2019-04-13 23:56:49 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-21 08:16:30 +0200

Seen: 109 times

Last updated: Apr 13