Ask Your Question
1

English/German Quotation Marks [closed]

asked 2013-06-11 02:01:22 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I use Writer to write documents in English and German. In Tools\AutoCorrectOptions I changed the quotation marks for the German (Switzerland) language setting from “aaa” to «aaa». But now Writer applies this setting also when the language is set to English. Do I always have to set the quotation mark options before typing or is it possible to set the type of quotation marks for each language individually?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-02 03:19:51.077131

Comments

manj_k gravatar imagemanj_k ( 2013-06-11 11:40:36 +0200 )edit
manj_k gravatar imagemanj_k ( 2013-06-11 12:19:13 +0200 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2013-06-11 12:04:24 +0200

manj_k gravatar image

updated 2013-06-11 12:07:09 +0200

In addition to my comments here.

You may try as follows:
Reset the Localized Options to Default, and use these macros for « and »
(in Writer)

Sub left_guillemet
Dim oDoc as variant
    oDoc = ThisComponent
Dim oCurrentController as variant
    oCurrentController = oDoc.getCurrentController()
Dim oTextViewCursor as variant
    oTextViewCursor = oCurrentController.getViewCursor()
Dim oText as variant
If IsEmpty(oTextViewCursor.Cell) Then
    oText=oTextViewCursor.Text
Else
    oText=oTextViewCursor.Cell.Text
End If
oText.insertString(oTextViewCursor,chr(clng("&H00AB")),false)
End Sub


Sub right_guillemet
Dim oDoc as variant
    oDoc = ThisComponent
Dim oCurrentController as variant
    oCurrentController = oDoc.getCurrentController()
Dim oTextViewCursor as variant
    oTextViewCursor = oCurrentController.getViewCursor()
Dim oText as variant
If IsEmpty(oTextViewCursor.Cell) Then
    oText=oTextViewCursor.Text
Else
    oText=oTextViewCursor.Cell.Text
End If
oText.insertString(oTextViewCursor,chr(clng("&H00BB")),false)
End Sub

Tools → Macros → Organize Macros → LibreOffice Basic... → Edit/New

Assign the macros to shortcut keys, e.g.:
« = Alt+Shift+L
» = Alt+Shift+R.

More details here and here.

edit flag offensive delete link more
0

answered 2013-06-11 05:36:04 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

@Huskey - in line with what @oweng I would install GER-CH.

I am running LibO English-US as default and have German-DE, Japanese and Dutch language supports installed. German runs fine. However, I did not attempt to change quotation marks but use the German-DE default ones.

Maybe you need also the French language support. Have a look if there is are French-F and French-CH language support.

edit flag offensive delete link more
0

answered 2013-06-11 05:08:37 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

You don't mention which version of English you are using. I think you need to have both language packs (e.g., en_GB/US/AU/etc and de_CH) installed for your version of LO in order for this aspect of AutoCorrect to work. It sounds like you only have English installed and not the de_CH language pack. AutoCorrect should be locale-dependent.

edit flag offensive delete link more
0

answered 2013-06-11 06:45:59 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

All the different languages run fine with the exception of the "Swiss" quotation marks because there are two sets. The problem is if German (Switzerland) is set as language, quotation marks are taken from German (DE) „aaa“ which is not wrong but not uniquely right. I think I found a solution: set language French (Monaco) and keyboard language German or English which gives me the desired outcome «aaa».

PS: French (F) puts correctly a space between quotation marks and letters « aaa ».

edit flag offensive delete link more

Comments

I feel that keyboard setting might create a conflict. I am using the setting for the physical keyboard I am using. In my case it is a Japanese keyboard for ALL languages I am writing. What kind of keyboard do you have and what are your settings?

ROSt52 gravatar imageROSt52 ( 2013-06-11 07:03:45 +0200 )edit

@Huskey, if you use a suitable Graphite font (e.g., Linux Libertine G) you can append :frsp=1 to the name of the font as an alternative method of obtaining the required French spacing.

oweng gravatar imageoweng ( 2013-06-11 08:26:00 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2013-06-11 02:01:22 +0200

Seen: 810 times

Last updated: Jun 11 '13