Ask Your Question
0

Exporting footnotes as text

asked 2019-03-24 06:20:43 +0200

dubeux gravatar image

Hello, I'm trying to export footnotes from LO 6 as text, to be used in Scribus. I've seen posts suggesting to use Alt. Find & Replace - I did it, copied the text, but when I paste it, line breaks are lost. I'd like to have the text, preserving the footnotes numbers and character formatting. I was able to paste only the footnotes (using the regular Find and replace) to a file, but as they still are footnotes, I can't select all. Any help?

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
1

answered 2019-03-24 16:29:06 +0200

Lupp gravatar image

The solution by @Craig22 seems to be thoroughly considered and structured. I allso played a bit with the topic, but did it the sloppy way.

However, since I collected the footnotes in an additional page at the end of the original textdocument, it was rather easy to retain the character formatting. (The paragraph format is slightly adapted to the needs as I saw them.)

See this attached example containing the code. It also contains a setting for the document only which adds a sensitive text for calling the routine to the Standard toolbar.

The code will not work in AOO.

edit flag offensive delete link more
1

answered 2019-03-24 12:31:32 +0200

Craig22 gravatar image

Hello,

I have written a macro for footnotes Export, etc.

It will certainly not fullfill all your wishes, but may be a start.

Start macro in the example document via the Commandbutton and wait for what happens:

C:\fakepath\Footenote Export to Calc.odt

Best Regards

Craig

edit flag offensive delete link more
0

answered 2019-03-24 17:52:03 +0200

dubeux gravatar image

Thank you very, very much for such quick and helpful replies. Pierre-Yves, I had already done that, but it wasn't of great help for what I wanted. Craig22 and Lupp, many thanks. With this last macro, I was able to copy and paste the result as rtf, retaining character formatting. As I didn't want the page numbers, I've removed it before, with regex (in case someone else wants the same):

\(Page: [:digit:]+\)\p

I've never written a macro, but when I have time, I'll play with it to adapt to my needs. But for now, it's working fine.

edit flag offensive delete link more
0

answered 2019-03-24 09:07:37 +0200

pierre-yves samyn gravatar image

Hi

This is indeed a limitation, inherited from OOo, and which has more recently been the subject of a request for enhancement.

To facilitate copying you can group the notes on the same page with the command : ToolsFootnotes and EndnotesFootnotes tab▸PositionEnd of document.

Regards

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-24 06:20:43 +0200

Seen: 53 times

Last updated: Mar 24