Ask Your Question
0

Entering a ⬛ changing the font on that line.

asked 2019-03-31 09:52:35 +0200

somedudewithproblems gravatar image

updated 2019-03-31 12:13:07 +0200

For some reason, when I enter a ⬛ character in Libre Office, it changes the font of the next character, or of the whole line. I guess this is a bug report?

Version: 6.0.7.3 Build ID: 1:6.0.7-0ubuntu0.18.04.2

Character: https://codepoints.net/U+2B1B

When selecting the font and the font all around it, the same font is indicated on the menu. Wherever I place this character, all the following characters become some sort of serif font, but it says they are still the non-serif font that I have selected.

  1. Set your font to Font Awesome
  2. Type "Testing 123" followed by a line break
  3. Type the character "⬛"
  4. Type "Testing 123" after that character
  5. The two fonts will look different, select the second one and see that it is still "Font Awesome"

It happens with "Lohit Gujarati", "Font Awesome", "KacstBook", "KacstOffice", "Pothana2000".

It does not happen with "Liberation Sans", "Baskerville", "Deja Vu Sans", "Roboto",

It appears to only mess things up when placed at the beginning of a sentence or some whitespace.

The font seems to remain broken after inserting the character throughout a document and then removing them all. Once they are all gone and you change the font size, the font will change style randomly at different sizes. Size 36, sans serif, size 40, serif, 48, serif, 54, back to sans serif???

edit retag flag offensive close merge delete

Comments

All the more if you think this is a bug, provide more technical details: what is the black square (Unicode code U+????)? LO version? OS?

Read these guidelines and edit (DO NOT USE ANSWER) your question for additional information.

ajlittoz gravatar imageajlittoz ( 2019-03-31 09:59:51 +0200 )edit

Can't reproduce here (same LO, Fedora 28, KDE desktop). How do you type the code point? Do you paste it from some other document? In the latter case, you may eventually paste other unwanted charactersIf it comes from a Writer/Word document, you may also import some formatting with it.

ajlittoz gravatar imageajlittoz ( 2019-03-31 10:32:47 +0200 )edit

<ctrl+shift+u> 2b1b <enter> I closed the program, opened a new document, repeated it, type the character by hand and was able to repeat the bug. Interestingly it only happens when it's set to "Font Awesome" font. The font is consistent in any other Sans Serif font, or any other font at all.

somedudewithproblems gravatar imagesomedudewithproblems ( 2019-03-31 10:38:16 +0200 )edit

Have followed your instructions, though I have no "Font Awesome". I tested with Liberation Sans, Baskerville (a serif font) and Gill Sans. No change in font appearance.

The key point may be the way of entering the Unicode char. I used 2b1b, then selecting the string and Alt+X.

ajlittoz gravatar imageajlittoz ( 2019-03-31 10:38:19 +0200 )edit

It happens with "Lohit Gujarati", "Font Awesome", "KacstBook", "KacstOffice", "Pothana2000".

It does not happen with "Liberation Sans", "Baskerville", "Deja Vu Sans", "Roboto",

somedudewithproblems gravatar imagesomedudewithproblems ( 2019-03-31 10:39:07 +0200 )edit

What are the particular properties of that font? Is it one of those OpenType font with selectable variants?

ajlittoz gravatar imageajlittoz ( 2019-03-31 10:40:05 +0200 )edit

Where can I examine the properties?

somedudewithproblems gravatar imagesomedudewithproblems ( 2019-03-31 10:42:01 +0200 )edit

Try with "Fontforge". You can download it as a package.

ajlittoz gravatar imageajlittoz ( 2019-03-31 10:44:17 +0200 )edit

Well font awesome appears to be an otf, but I'm not sure what I can learn in font forge. All the characters appeared to be blank.

somedudewithproblems gravatar imagesomedudewithproblems ( 2019-03-31 10:55:27 +0200 )edit

Actually I apparently have three versions of FontAwesome installed, an OTF a WOFF and a TTF. So... I don't know which one it's using. All the other fonts that have the problem are all TTF, but all the other fonts that don't have the problem are also TTF. So I don't think it's determined solely on the format.

somedudewithproblems gravatar imagesomedudewithproblems ( 2019-03-31 10:57:35 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2019-04-01 20:51:55 +0200

LibreTraining gravatar image

updated 2019-04-01 20:53:36 +0200

If you can replicate this and provide an example document you should file a bug report.
Include the same document as Export to PDF.

That character does not exist in the fonts I checked: FontAwesome 5 Free Regular and Solid, KacstBook, KacstOffice, Pothana2000, Liberation Sans, Deja Vu Sans, Roboto, Noto Sans, Ubuntu, and Arial Unicode.
So LibreOffice is having to find this character in some font and do a replacement.

LibreOffice is looking for that character in other installed fonts.
On my system it found it in CormorantUpright-Light - an odd choice and a bit random.

In LibreOffice this replacement is annoyingly done with no indication/info to the user to see what has happened.
The only way to see the actual fonts being used is to Export to PDF and then examine the PDF Text Properties.
That is how I can see my replacement font is CormorantUpright-Light on that character.

You can also get an idea of what is happening by copying the characters from the PDF into a Unicode tool.
Such as: http://babelstone.co.uk/Unicode/whatisit.html
Then you may be able to see what hidden characters also are present.

You may want to use the Insert Special Characters dialog to pick that character from a font which actually has that character thereby avoiding LibreOffice doing the replacement (which could be the problem).
That may avoid the issue as a workaround.

.

edit flag offensive delete link more
0

answered 2019-03-31 10:03:38 +0200

ajlittoz gravatar image

Do you really think the font is changed? Please check the various drop-down menus in the toolbar to verify the font and font size remain the same.

It is likely that your black square symbol comes from a dingbats font. Dingbats font usually have a wider linespacing than "ordinary" font. When mixing characters from fonts with non equal properties, the largest property is used so that characters on current line do not "collide" with preceding line, thus creating a wider inter-line spacing, giving the illusion that font size was enlarged.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2019-03-31 09:52:35 +0200

Seen: 154 times

Last updated: Apr 01