Ask Your Question

How Do I Get LibreOffice Icons To Appear In The KDE Plasma 5 Task Manager?

asked 2019-04-02 17:59:06 +0100

Keltonix gravatar image

How can I fix the LibreOffice icons not appearing in the KDE Plasma 5 Task Manager in the main panel?

LibreOffice Version:; Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d KDE Plasma: 5.15.3 Kernel: 5.0.4 Workspace Theme: Oxygen Application WIdget Style: qtcurve Window Decorations: OS X Icon Set: Oxygen

No LibreOffice icons appear in the Task Manager on the default panel. Rather, a generic X-application icon represents the running component (such as Writer, Calc, Impress, etc.).

When a component of LibreOffice is starting up, the icon for that component appears for a ½ second or so, but then it is replaced with the generic X-application icon

edit retag flag offensive close merge delete


What is your distro? Here, Fedora 29 OK, Fed 28 OK. (Edit your question doin't use an answer)

ajlittoz gravatar imageajlittoz ( 2019-04-02 20:41:29 +0100 )edit

@ajlittoz I think it is not a matter of the distro but the LO repository and the packages installed. On my openSUSE Leap 15.0 system, I do use RPM packages from and observe the native X symbol as mentioned in the post. On a Fedora 29 system, where I installed from Fedora repository using dnf install libreoffice I do see the LibreOffice symbols in the task bar.

Opaque gravatar imageOpaque ( 2019-04-03 10:36:01 +0100 )edit

I have — before clean installing PCLinuxOS 2019 — gone through the trouble of uninstalling LibreOffice using Synaptic, then downloaded the LibreOffice RPMs from, unpacked the RPMs, moved the libobasis6.2-en-US-help- into the same directory as the rest of the RPMs, and then run # rpm -Uvih *rpm

I still had the same problem of LibreOffice icons not displaying in the Task Manager when one of the component programs of LibreOffice was running. One of the reasons I did the clean install was because I had hoped that there was some sort of configuration glitch on my system that would be fixed with a clean install. But NOPE. That didn't work.

Keltonix gravatar imageKeltonix ( 2019-04-03 11:13:03 +0100 )edit

Just installed RPM packages from (6.2.2) on Fedora 29 and this verifies the observation from the post (at least for my system).

Opaque gravatar imageOpaque ( 2019-04-03 11:13:22 +0100 )edit

2 Answers

Sort by » oldest newest most voted

answered 2019-07-08 16:54:06 +0100

Spinnekop gravatar image

Same problem in KDE plasma 5.16 - tried with latte dock plasmoid as well as icons only task manager. Same thing happens in deepin as well as gnome on wayland but not on X.

edit flag offensive delete link more


Please do not post as an answer, if you actually don't provide a solution to OPs original question. Use "add a comment" function instead. Thanks in advance ...

Opaque gravatar imageOpaque ( 2019-07-08 17:51:20 +0100 )edit

answered 2019-04-03 11:21:17 +0100

Opaque gravatar image

updated 2019-04-03 11:23:26 +0100

Hello Keltonix,

my solution is to remove the .cache directory in $HOME directory: rm -r ~/.cache, to logout from the KDE session and to login again.

Hope this also works for you.

edit flag offensive delete link more


Happily, my fave distro just updated KDE Plasma to 5.15.4. And don't you know that this particular update fixed the LibreOffice icon snafu — for now.

Keltonix gravatar imageKeltonix ( 2019-04-04 15:53:18 +0100 )edit

2019-07-09; 18:03 U.S. Eastern Time I am Keltonix. I just got an email notification about this thread having new input. I'm thankful to all who commented and/or answered.

I'm now running KDE Plasma 5.16.2-3 and LibreOffice 6.2- All the icons are as they should be. But, next time I run into this problem (and I'm sure that there will be a next time), I'll be sure to remember to clear ~/.cache and logout/login.

Keltonix gravatar imageKeltonix ( 2019-07-10 00:11:25 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2019-04-02 17:59:06 +0100

Seen: 323 times

Last updated: Jul 08