How Do I Get LibreOffice Icons To Appear In The KDE Plasma 5 Task Manager?

How can I fix the LibreOffice icons not appearing in the KDE Plasma 5 Task Manager in the main panel?

LibreOffice Version:;
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
KDE Plasma: 5.15.3
Kernel: 5.0.4
Workspace Theme: Oxygen
Application WIdget Style: qtcurve
Window Decorations: OS X
Icon Set: Oxygen

No LibreOffice icons appear in the Task Manager on the default panel. Rather, a generic X-application icon represents the running component (such as Writer, Calc, Impress, etc.).

When a component of LibreOffice is starting up, the icon for that component appears for a ½ second or so, but then it is replaced with the generic X-application icon

What is your distro? Here, Fedora 29 OK, Fed 28 OK. (Edit your question doin’t use an answer)

@ajlittoz I think it is not a matter of the distro but the LO repository and the packages installed. On my openSUSE Leap 15.0 system, I do use RPM packages from and observe the native X symbol as mentioned in the post. On a Fedora 29 system, where I installed from Fedora repository using dnf install libreoffice I do see the LibreOffice symbols in the task bar.

I have — before clean installing PCLinuxOS 2019 — gone through the trouble of uninstalling LibreOffice using Synaptic, then downloaded the LibreOffice RPMs from Download LibreOffice | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft, unpacked the RPMs, moved the libobasis6.2-en-US-help- into the same directory as the rest of the RPMs, and then run # rpm -Uvih *rpm

I still had the same problem of LibreOffice icons not displaying in the Task Manager when one of the component programs of LibreOffice was running. One of the reasons I did the clean install was because I had hoped that there was some sort of configuration glitch on my system that would be fixed with a clean install. But NOPE. That didn’t work.

Just installed RPM packages from (6.2.2) on Fedora 29 and this verifies the observation from the post (at least for my system).

Hello Keltonix,

my solution is to remove the .cache directory in $HOME directory: rm -r ~/.cache, to logout from the KDE session and to login again.

Hope this also works for you.

Happily, my fave distro just updated KDE Plasma to 5.15.4. And don’t you know that this particular update fixed the LibreOffice icon snafu — for now.

2019-07-09; 18:03 U.S. Eastern Time
I am Keltonix. I just got an email notification about this thread having new input. I’m thankful to all who commented and/or answered.

I’m now running KDE Plasma 5.16.2-3 and LibreOffice 6.2- All the icons are as they should be. But, next time I run into this problem (and I’m sure that there will be a next time), I’ll be sure to remember to clear ~/.cache and logout/login.

Same problem in KDE plasma 5.16 - tried with latte dock plasmoid as well as icons only task manager. Same thing happens in deepin as well as gnome on wayland but not on X.

Please do not post as an answer, if you actually don’t provide a solution to OPs original question. Use “add a comment” function instead. Thanks in advance …