Ask Your Question
0

Calc hangs when trying to save my spreadsheet to xls/xlsx (4.0.3.3 and 4.1.0b) [closed]

asked 2013-06-15 15:32:53 +0200

einpoklum gravatar image

updated 2015-08-29 21:42:32 +0200

Alex Kemp gravatar image

I'm trying to save a (bit complex, but not that terrible) spreadsheet in .xls or .xlsx format. Unfortunately, when I do this, the progress bar goes up to about half, then LO hangs.

Is this a known issue? How can I circumvent this problem?

I've tried this with both 4.0.3.3 and 4.1.0b, on Windows 7.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-11 07:15:05.944758

Comments

1

Which LIbO and which OS version are you using? This information is important to help you.

ROSt52 gravatar imageROSt52 ( 2013-06-16 03:58:20 +0200 )edit

@ROSt52: done.

einpoklum gravatar imageeinpoklum ( 2013-06-21 17:15:03 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2013-06-23 09:33:44 +0200

oweng gravatar image

Probably a bug and quite possibly a known bug. How long did you wait before canceling the process? Does CPU/RAM spike? Any additional observations you can make will help.

Please have a look through the list of open xls+save bugs and see if any describe your specific issue. If none do, please report a bug and provide as much detail about your particular case as possible. In either case (found or newly raised bug) please report the related bug number back here in a comment beneath this answer in the form "fdo#123456". For a newly reported bug, please provide an example file. Thanks.

edit flag offensive delete link more

Comments

I can't reproduce, so let's assume it's one of the bugs on the list. Thanks.

einpoklum gravatar imageeinpoklum ( 2014-06-20 17:07:38 +0200 )edit
0

answered 2013-10-15 14:44:45 +0200

Jantjooh gravatar image

updated 2013-10-15 14:56:41 +0200

I have the same problem with all version 4.1.x versions, when saving ODG (Draw) files. The working window can be dead for up to 1 minute during save. My processor workload indeed spikes up to 30% in 2 cores Intel I7 quad. (Where the load normally is ~ 3%). This is an intermittent problem. Windows 7, 64 bit. I downloaded the latest 4.1.2.3 version on 2013/10/14 I believe the problem did not exist in 4.0.x.x (I may test that, because I saved the installation file) Jan. [edit] I did some testing, and found when I delete a picture from the document (size= 750KB) there is little delay, saving! However I'm shure in previous levels, the contents had little effect in save time. Also a "warning" is displayed in the active window: "LibreOffice is notresponding" [/edit]

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-06-15 15:32:53 +0200

Seen: 1,748 times

Last updated: Oct 15 '13