Ask Your Question
0

Writer: What Macros

asked 2019-05-03 03:28:43 +0200

mark gravatar image

updated 2019-05-07 04:57:13 +0200

I have a document which always gives me a Macro warning when I open it.

The thing is, as far as I can tell, there are no macros. It may have had some a long time ago, and it was attached to a template with macros a long time ago, but I can’t find any evidence of any current macros.

I have checked everything available in the Tools Macro item, both organising and editing, and cannot find anything to delete.

How do I find and delete these mysterious macros?

Using MacOS , LO 6.2.0.3

C:\fakepath\html101-blank.odt

edit retag flag offensive close merge delete

Comments

Can you create a copy, remove all text and upload the blank file still showing the macro warning?

Opaque gravatar imageOpaque ( 2019-05-03 09:58:29 +0200 )edit

Sorry I missed your comment.

I have created a blank version of the document, and the Macro warning still appears.

How do I upload the file?

mark gravatar imagemark ( 2019-05-06 05:19:12 +0200 )edit

Edit your original question and upload a file using the clip icon. Are you using MacOS Mojave? Allow me one remark regarading LO 6.2.0.3. This was the very first 6.2 release and I really do not recommend to use this version any longer. For my taste it had too many bugs.

Opaque gravatar imageOpaque ( 2019-05-06 08:22:25 +0200 )edit

I have uploaded the blank document now. As regards your comments on versions, yes, I am using Mojave, and I was using LO 6.2.0.3. I have now updated to 6.2.3.2, if that is any better? Maybe it won’t crash quite so often.

mark gravatar imagemark ( 2019-05-07 05:21:11 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-05-07 09:14:00 +0200

Opaque gravatar image

Hello Mark,

thanks for uploading the test file. The issue with your file is, that there is an empty library called "Project" and this causes the macro warning. To get rid of this library and in consequence to avoid the macro warning, you need to perform the following actions (I've renamed the file for the following screenshots to MacroIncludedMyCopy.odt)

  • Open the file
  • Go to Tools -> Macros -> Organize Macros -> LibreOffice Basic and select your file in Macro From (You'll notice 2 libraries called "Project" and "Standard")

image description

  • Click on button Organizer and select tab Libraries
  • Select your file in the dropdown called Location (existing 2 Libraries show up)

image description

  • Select library "Project" and click buttons Delete and Close
  • Click button Close on the returning dialog
  • Save your file

Hope that help - if yes, please click the check mark ✓ next to the answer.

edit flag offensive delete link more

Comments

You know, I looked everywhere for that, but I never dug down deeply enough. Thanks so much for your work and your answer.

mark gravatar imagemark ( 2019-05-08 03:49:19 +0200 )edit

Please click the check mark ✓ next to the answer to demonstrate that your problem has been solved - thanks in advance.

Opaque gravatar imageOpaque ( 2019-05-08 08:48:58 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-05-03 03:28:43 +0200

Seen: 74 times

Last updated: May 07