Base date format problem - swapping DD/MM

asked 2019-05-05 14:42:27 +0200

Rolandvl gravatar image

updated 2019-05-06 10:47:32 +0200

I created a new embedded Firebird-database. I defined in this database a table with a field 'DATE1' in it. Now I want to add data to this table. Double click on this table name, I fill in a date in this field like 10/05/19, the system changes that to 05/10/19. What is going on with Firebird embed? With HSQL in the past (older versions of LibreOffice), a date like 10/05/19 stays 10/05/19. In Belgium and France we note dates as DD/MM/YY. This swapping happens only when Day<=12. For example 13/05/19 stays 13/05/19, but 12/05/19 becomes 05/12/19. Very strange.

My local settings Options/Language Settings are: -User Interface: Default - English (USA) -Locate setting: Dutch(Belgium) -Date acceptance patters: D/M/Y

Libreoffice v 6.1.5.2 on Windows 10 and Firebird-database created and embedded in Base.

What can I do that 10/05/19 stays 10/05/19 (DD/MM/YY)?

edit retag flag offensive close merge delete

Comments

Hmm - you did no tell which format you specified for the column at definition time and whether you changed on the table and all in all your definitions are not constructed to avoid ambiguity [10,05] could be D or M or Y and 19 could be or Y or D. So I recommend to stick to ISO code (YYYY-MM-DD) on all levels and leave everything else to a later representation of your data.

Opaque gravatar imageOpaque ( 2019-05-05 17:19:47 +0200 )edit

I specified nothing special at the definition only field-type:DATE. I assumed that a correct format is DD/MM/YY because the Locale Settings is Dutch(Belgium) and the Date pattern is D/M/Y. I did also a test with a specified user format: Dd/MM/YY, with the same result: swapping. I did tests with other Local Settings (France) with the same result: swiping D/M. In fact you have only problems when you use a / as separator. Other separators German (.) or Dutch Netherlands (-): no swapping so ok. This non-consistent behaviour means a bug which was not there in older Libreoffice version.

Rolandvl gravatar imageRolandvl ( 2019-05-05 17:49:54 +0200 )edit

Please check in design mode, whether Format dialog shows really "Dutch(Belgium)" in category "Language". On my Base there is no such conversion, even if I do not specify an format code explicitly - but I use 6.2.3.2 on Linux.

Opaque gravatar imageOpaque ( 2019-05-05 18:06:08 +0200 )edit

Yes I checked Locale setting: "Dutch(Belgium)": is on, but also with French(France)- settings we have the same problem: swapping M/D.

Rolandvl gravatar imageRolandvl ( 2019-05-05 18:35:35 +0200 )edit

I did not talk about Locale in Tools - > Options ... but in Language setting in base table design mode - just to be clear.

Opaque gravatar imageOpaque ( 2019-05-05 22:09:18 +0200 )edit

Sure, in Table Design Mode (Field Dialog Panel) is set to Dutch(Belgium), verified also on right click on column heading in table view: Column Format and then Format Code: DD/MM/JJ

Rolandvl gravatar imageRolandvl ( 2019-05-06 10:55:57 +0200 )edit