Ask Your Question
0

How to revert back to pre-LibreOffice System Fonts? [closed]

asked 2013-06-21 08:05:03 +0100

Loafers gravatar image

updated 2015-11-02 21:50:14 +0100

Alex Kemp gravatar image

After installing LibreOffice, I noticed my fonts looked different despite using the same typeset. In the past, deleting MS fonts fixed the issue, but it is not even installed this time.

What should I try doing? Please advise.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-02 21:50:28.938224

Comments

Which version of LibreOffice you installed (Help | About menu)? Which Windows? Where do you see this problem of fonts - in LibreOffice, somewhere else? Are you using the same LibreOffice profile or did you clean uninstall it and install it back? Please explain more.

L-user gravatar imageL-user ( 2013-06-21 10:50:29 +0100 )edit

My version is 1:4.0.3-3 and I am running Debian Testing. My apologies for originally not including this information.

Loafers gravatar imageLoafers ( 2013-06-21 20:58:33 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-06-22 02:24:36 +0100

oweng gravatar image

updated 2013-06-22 07:23:08 +0100

You do not mention which font is displaying problems or what the nature of the problem is. Is the problem something similar to that shown in this infinality forum thread?

FreeType / infinality

From the comment beneath this answer it appears that the problem was not the LO-supplied fonts but rather the FreeType rendering engine, and in particular the infinality patches extension. A re-install of infinality seems to have fixed the problem.

LO-supplied fonts (Original answer)

Is your problem with the Gentium or Liberation font family? LO v4.0 ships a relatively recent version of these fonts and so would seem the most likely issue, although you are using Debian from the testing repository, which I thought would be up-to-date anyway. Under Crunchbang 11 (basically Debian stable, so bear that in mind):

$ ls /usr/share/fonts/truetype/

... I have gentium/, gentium-basic/, liberation/, ttf-dejavu/, and ttf-liberation/ directories among others. The LO installed fonts are here:

$ ls /opt/libreoffice4.0/share/fonts/truetype/

... where you will notice versions of these same (or similar) fonts. The DejaVu fonts appear to the same version as shipped with LO v4.0. The Gentium and Liberations fonts however differ in that the LO ones are a more up-to-date version.

You can easily revert by moving the relevant LO-supplied font to a different location.

edit flag offensive delete link more

Comments

1

Ok everything is fine now. I removed fonts-liberation and re-installed infinality. Though I believe the latter was the actual fix.

Loafers gravatar imageLoafers ( 2013-06-22 04:56:43 +0100 )edit

Thanks for reporting back. I will update my answer.

oweng gravatar imageoweng ( 2013-06-22 07:09:08 +0100 )edit

Question Tools

Stats

Asked: 2013-06-21 08:05:03 +0100

Seen: 264 times

Last updated: Jun 22 '13