Ask Your Question
0

insert field database next record only works once

asked 2019-06-03 22:41:37 +0200

Carrbigdog gravatar image

updated 2019-06-06 06:29:21 +0200

I have created a writer document that contains a table with the first column of each row containing multiple database fields. In the second entry, I position my cursor in the first position in the table entry and select Insert -> Field -> More Fields -> (Database Tab) -> Next Record -> Insert. I repeat this in the third, fourth and fifth rows. When I print the document, only the first two rows are populated with information from the spreadsheet, the other rows are blank. Is there a limit on the number of fields that may be inserted into a page, is this a bug or might I be doing something else that is causing this not to work? Any help would be greatly appreciated.

I recreated the database with test data and used Exchange database to connect to the new version. The db has nine rows. It resulted in the same outcome. Here is the document: image description

Here is the result: image description


Attached the files: C:\fakepath\CatalogEntryPage.odt C:\fakepath\TestWTDbase.odb If you need anything else, please let me know and I do appreciate you looking at this.

sorry for the missed upload: C:\fakepath\TestSpreadSht1.ods

edit retag flag offensive close merge delete

Comments

@Carrbigdog Unfortunately from the images there does not seem to be a problem. If possible and since you have created a new test DB, could you post you DB and writer files to test? Otherwise I will need to try and completely re-create what you have which may entail some guessing.

Ratslinger gravatar imageRatslinger ( 2019-06-06 00:08:29 +0200 )edit

@Carrbigdog Your database is created based upon a Calc file. Need that also to complete all links.

Ratslinger gravatar imageRatslinger ( 2019-06-06 01:10:24 +0200 )edit

@Carrbigdog Sorry if you missed it, but the solution is already in my answer as the last edit.

Ratslinger gravatar imageRatslinger ( 2019-06-06 06:41:02 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2019-06-04 01:12:49 +0200

Ratslinger gravatar image

updated 2019-06-06 02:04:05 +0200

Hello,

Not quite certain of your layout and only used three records in my test, but had no problem:

image description

Output is:

image description

Don't know that there is a limit on number of fields.

Edit - Modified 2019-06-05:

Did this with a Q&D DB & Writer Doc. Will look at your posted data I just saw:

image description

Output:

image description

So far no problem. Will look at your data.

Edit #2 2019-06-05:

Found the problem! Ctrl + F10 toggle formatting marks:

image description

In the first section look at the very last field - <Handler_Last_Name>. The return is also part of the field. Place a space or two after the data name and all should work.

This may help, Writer file I used. Just exchange the DB --- DogsWriter.odt

edit flag offensive delete link more

Comments

Just expanded it to five rows/records without problem.

Ratslinger gravatar imageRatslinger ( 2019-06-04 01:22:18 +0200 )edit

Thanks for looking at this.

Carrbigdog gravatar imageCarrbigdog ( 2019-06-05 23:55:58 +0200 )edit

It appears each section had a problem with <Handler_Last_Name>. Try my attached file.

Ratslinger gravatar imageRatslinger ( 2019-06-06 02:08:57 +0200 )edit

Have used your data and my fixed Writer file (see answer edit) and all records are output to the print file.

Ratslinger gravatar imageRatslinger ( 2019-06-06 06:58:48 +0200 )edit
0

answered 2019-06-06 07:48:00 +0200

Carrbigdog gravatar image

updated 2019-06-06 07:50:42 +0200

Thank you so much for your assistance. Error was in the formatting of the line containing the last database field. I copied and pasted from row 2 to the remainder of the rows which made it worse. Guess I should build these a row at a time in the future to narrow down the potential problem areas. Ratslinger you are fantastic.

edit flag offensive delete link more

Comments

@Carrbigdog In future only use answer to actually answer original question (even if it is your question). Otherwise use add a comment.

Glad all worked out - BTW I actually did Copy/paste once I found the problem. Getting the first correct is the key.

Ratslinger gravatar imageRatslinger ( 2019-06-06 18:33:14 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-06-03 22:41:37 +0200

Seen: 62 times

Last updated: Jun 06