Ask Your Question

Multi language spell check [closed]

asked 2012-04-15 11:17:01 +0100

dyrer gravatar image

updated 2012-07-12 16:37:32 +0100

manj_k gravatar image

Hello, first i want to congratulate all libre office devs and supporters Now I have a problem, I have complex documents with both English and Greek documents and spell check only check ONE language. How can solve this problem, thanks in advance

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-27 19:57:46.036124

4 Answers

Sort by » oldest newest most voted

answered 2012-04-15 13:01:00 +0100

manj_k gravatar image

updated 2012-04-15 18:10:57 +0100

(1) You have installed both dictionaries (English, Greek)?

(2) You have selected the correct text language?

For further details → LibreOffice Writer Guide.

Chapter 3 - Working with Text

Checking spelling (p. 22)

You can change the dictionary language on the Spelling and Grammar dialog box, e.g.: image description

Using built-in language tools (p. 23)

"Writer provides some tools that make your work easier if you mix multiple languages within the same document or if you write documents in various languages:

Paragraph and character styles

Using Tools > Language

Using language settings in Options

Using the status bar [...]"

edit flag offensive delete link more

answered 2012-04-15 12:22:56 +0100

Pedro gravatar image

LibreOffice can spell check in any number of languages. However it does not detect the languages automatically.

You need to check that you have both the English and Hellenic dictionaries in menu Tools, Extension Manager. Set the language for the document to the dominant language. Then just select the part in the other language and select the menu Tools, Language, For Selection.

If you have done all this and it is not working specifically with Hellenic, then it is a bug and needs to be reported.

edit flag offensive delete link more

answered 2012-11-19 15:09:28 +0100

Epoca Libera gravatar image

updated 2012-11-19 16:02:51 +0100

Hello, I have tried LibreOffice, and now it is very useful for me.

After having a problem with bilingual or complex documents, I have discovered that if you want to paste text (formated or unformated) in your document, firstly you have to select the language of the text to be pasted, at Tools>Language>For selection.
If the language of the text to be pasted, is different than the language selected there, the "AutoSpellcheck" and The "Spell and Grammar" will fail to recognize the language of the pasted text, and it will be underlined in red on the document. If this happens, then the only way to solve it, is to delete the pasted text, and paste it again, after selecting the correct language at the 'For Selection' field.

edit flag offensive delete link more



answered 2013-03-29 20:51:47 +0100

nitro912gr gravatar image

I have the same problem, but only in macOSX and ubuntu. In windows somehow libre office can see that I changed the input language and change the paragraph language as well.

I just don't understand why this is not happening with the versions for mac and linux, I mean I don't know about programming, but is it that hard to have libre office to check what is the system language at the moment you are typing?

It can be done, that's for sure since I have this working since the days I was using open office 3 in windows XP and vista and still use it under windows 7 and libre 4.

edit flag offensive delete link more


Question Tools

1 follower


Asked: 2012-04-15 11:17:01 +0100

Seen: 18,731 times

Last updated: Mar 29 '13