Ask Your Question
0

csv default separator

asked 2019-07-14 13:59:26 +0200

knorre gravatar image

updated 2019-07-14 14:47:21 +0200

How to set semicolon as a default separator for CSV files? I can do it by "Save as" and selecting "edit filter settings". But I am very tired to do it each time I saving the table. Using just "save" replaces semicolons with commas.

Version: 6.2.4.2 Build ID: 1:6.2.4-0ubuntu0.19.04.1

edit retag flag offensive close merge delete

Comments

I think a macro is the only way.

gabix gravatar imagegabix ( 2019-07-14 14:44:57 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-07-14 16:32:08 +0200

Opaque gravatar image

updated 2019-07-14 16:33:00 +0200

Hello

go to Tools -> Options - LibreOffice -> Advanced - Button: Open Expert Configuration and search for FieldSeparator - change the value for Preference Name CSVExport -> Property FieldSeparator to string ";" (w/o quotation marks).

image description

This works for me on:

Version: 6.2.5.2
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
edit flag offensive delete link more

Comments

Thank you! I've checked CSVExport parameters. In my case, it was the semicolon.

I figured out that the problem takes place during the importing of file. If I am importing semicolon separated file and then save it to csv, semicolons are being replaced by the commas. It is very annoying.

knorre gravatar imageknorre ( 2019-07-14 17:03:47 +0200 )edit

I agree, strange. But it is reproducible and annoying. Just make ";" separated file, open it with calc and press "save". By doing this I always see the commas instead of ";".

knorre gravatar imageknorre ( 2019-07-14 18:20:20 +0200 )edit

From my perspective a bug - since a "Save" doesn't honor the setting in Advanced configuration while "Save As" with ticking "Edit filter settings" (just shown the settings but not changing anything) does honor the setting. But maybe a personal misconception (the setting is about -Dialogs).

But my answer - and that's what I've testet before posting - was about "How to set semicolon as a default separator for CSV files". There was no mention about, that you start with importing a csv file and that's why this different use case had not been tested in advance of posting my answer.

Opaque gravatar imageOpaque ( 2019-07-14 18:31:56 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-07-14 13:59:26 +0200

Seen: 32 times

Last updated: 2 days ago