Csv default separator

How to set semicolon as a default separator for CSV files?
I can do it by “Save as” and selecting “edit filter settings”. But I am very tired to do it each time I saving the table.
Using just “save” replaces semicolons with commas.

Build ID: 1:6.2.4-0ubuntu0.19.04.1

I think a macro is the only way.


go to Tools -> Options - LibreOffice -> Advanced - Button: Open Expert Configuration and search for FieldSeparator - change the value for Preference Name CSVExport → Property FieldSeparator to string “;” (w/o quotation marks).

This works for me on:

Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Thank you!
I’ve checked CSVExport parameters. In my case, it was the semicolon.

I figured out that the problem takes place during the importing of file. If I am importing semicolon separated file and then save it to csv, semicolons are being replaced by the commas. It is very annoying.

I agree, strange. But it is reproducible and annoying. Just make “;” separated file, open it with calc and press “save”. By doing this I always see the commas instead of “;”.

From my perspective a bug - since a “Save” doesn’t honor the setting in Advanced configuration while “Save As” with ticking “Edit filter settings” (just shown the settings but not changing anything) does honor the setting. But maybe a personal misconception (the setting is about -Dialogs).

But my answer - and that’s what I’ve testet before posting - was about “How to set semicolon as a default separator for CSV files”. There was no mention about, that you start with importing a csv file and that’s why this different use case had not been tested in advance of posting my answer.

It’s worse than that. Both Save and Save As don’t honor the advanced settings, only the "Edit Filter Settings dialog does, and when ticked, will override the values that Save As would use otherwise.