Ask Your Question
1

LO3.5.2 Writer slow on startup [closed]

asked 2012-04-19 00:14:49 +0200

jmjf gravatar image

updated 2015-10-15 23:29:06 +0200

Alex Kemp gravatar image

Win7 64-bit, Core i5-5xx, 8GB LO3.5.2. Language Tool 1.7 installed (but doesn't make a difference) Only English dictionaries installed.

Open 700+ page document in Writer 3.5.2. After 2-3 seconds, soffice.bin process goes 25% CPU (i.e., 100% of it's 1 core) for about 2m15s (timed it). During this CPU spike, LO can't really do anything because response to typing is so S-L-O-W.

3.4.6 opens this document and is ready to go. No slow typing. No delays. No CPU spikes. What changed in 3.5.2's document open procedures to cause this CPU spike and consequent usability problem?

Notes:

  • The document is plain text. Basic margins and a header (page number). No images, tables, bullets, etc. After the CPU-pegging is done, 3.5.2 seems to work reasonably well.
  • Opening a much smaller document in 3.5.2., I see a short 25% CPU spike for <5 seconds, so this seems to be related to document size.
  • 3.5.2 is not counting pages, etc. It has the right page count as soon as the document displays on screen.
  • 3.5.2 does not appear to be spell-checking. I see red wavy underlines before the CPU spike. I can jump to the end of the document before the spike starts and see red wavy underlines there. Likewise, a fast set of page downs before the spike shows red wavy underlines. And just to be sure, I tested with 300 page lorem ipsum which throws red wavy underlines under every word, so it's really obvious it had spell checked.

19 April 2012 Update

Thanks to manj_k for the update. Hopefully that's it and they get it fixed soon.

In the interest of having correct information, further testing showed that 3.5.2's issue is not just a file open issue. Once the file is open, typing new text spikes the CPU core (CPU = 25%) every time.

I reverted to 3.4.3 (apparently didn't move the 3.4.6 install package to a safe place and didn't feel like DLing again). 3.4.3 also spikes the CPU to 25% on file open (100% of 1 core) for about a couple of minutes, so my conclusion that this is a file open problem is wrong. But 3.4.3. doesn't have the slow typing ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-15 23:29:23.512656

Comments

HI @jmjf -- Did v3.5.3 fix the problem for you? I've heard from a number of users of some slow downs moving from the 3.4 -> 3.5 branches.

qubit gravatar imagequbit ( 2013-01-26 21:37:37 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2012-04-19 01:26:45 +0200

manj_k gravatar image

I've also seen a major difference (v3.4.6/v3.5.2--on WinXP).

Maybe related to → Bug 48011 - LibreOffice 3.5 is unusably slow with large documents.

There's a → patch, planned for LO 3.5.3-rc1.

edit flag offensive delete link more

Comments

manj_k gravatar imagemanj_k ( 2012-04-19 01:33:09 +0200 )edit

Question Tools

Stats

Asked: 2012-04-19 00:14:49 +0200

Seen: 1,173 times

Last updated: Apr 19 '12