Ask Your Question
0

Calc rounding problem when import from CSV or pasting [closed]

asked 2013-07-18 12:45:47 +0200

Ramon Valdezz gravatar image

updated 2015-09-11 21:55:06 +0200

Alex Kemp gravatar image

I use last LibreOffice release on Windows 8 64-bit.

I have to import a csv file with decimal numbers. When i open the csv with Calc, the number are stored (not only displayed) with less decimal than the source.

Example:

627511,07554523856 (csv source file)

627511,075545239 (value stored in .ods file cell)

The only way i found to store the whole numbers inside the cells is importing the csv as text. But when i use the function "VALUE" to convert them as number, the same rounding problem appears. I realized that the same is happening when i copy a single number (ctrl+c) and i paste it inside a cell (ctrl+v).

What's is going on? Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 17:17:24.189878

2 Answers

Sort by » oldest newest most voted
1

answered 2013-07-18 17:35:24 +0200

horst gravatar image

There is no error in CALC. All spreadsheets I know work with 64bit real numbers also for integer values which gives you only 15 digit accuracy.

edit flag offensive delete link more
0

answered 2014-03-03 12:02:47 +0200

tomekk gravatar image

updated 2014-03-03 12:12:25 +0200

How to disable this function? I'm importing csv with number 2014022469001199, and LibreOffice Calc show me 2014022469001200 (It's OTRS ticket number ;) I want to copy it and paste in some browser filter) Can I turn this off?

edit flag offensive delete link more

Comments

If you don't have to calculate with this number import it as Text.

horst gravatar imagehorst ( 2014-03-03 16:57:33 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2013-07-18 12:45:47 +0200

Seen: 830 times

Last updated: Mar 03 '14