Calc rounding problem when import from CSV or pasting

I use last LibreOffice release on Windows 8 64-bit.

I have to import a csv file with decimal numbers.
When i open the csv with Calc, the number are stored (not only displayed) with less decimal than the source.


627511,07554523856 (csv source file)

627511,075545239 (value stored in .ods file cell)

The only way i found to store the whole numbers inside the cells is importing the csv as text.
But when i use the function “VALUE” to convert them as number, the same rounding problem appears.
I realized that the same is happening when i copy a single number (ctrl+c) and i paste it inside a cell (ctrl+v).

What’s is going on?

There is no error in CALC. All spreadsheets I know work with 64bit real numbers also for integer values which gives you only 15 digit accuracy.

How to disable this function?
I’m importing csv with number 2014022469001199, and LibreOffice Calc show me 2014022469001200 (It’s OTRS ticket number :wink: I want to copy it and paste in some browser filter)
Can I turn this off?

If you don’t have to calculate with this number import it as Text.