Ask Your Question
0

How to reset LANG/Font

asked 2019-08-12 23:01:42 +0200

kprice789 gravatar image

updated 2019-08-14 00:13:45 +0200

I have user that is having some Font or Language issue, not really sure what it is but it needs to get reset. Preferably from the CLI since the menus are difficult to navigate. Interestingly, no one else on this server seems to experience the same issue. So I feel like it's something with the users home directory but not sure where this setting may be stored. It affects all of her LibreOffice applications, but not other applications. Has anyone seen this before?

Tools -> Options -> Language Settings -> Languages image description

Tools -> Options -> Libre Office Writer -> Basic Fonts (Western) image description

CentOS 6.10 2.6.32-754.9.1.el6.x86_64 LibreOffice Version: 4.3.7.2 Build ID: 4.3.7.2-2.el6_9.2

Thank you!

edit retag flag offensive close merge delete

Comments

Please edit your question to describe the symptoms. Your screenshot is not very legible. Is is a substitution? Looks like you have Greek letters but words are in English which suggests some symbols font is active. Have you tried Tools>Options, LibreOffice Writer>Basic Fonts (Western)?

ajlittoz gravatar imageajlittoz ( 2019-08-13 08:04:04 +0200 )edit

I've updated the images with hopefully more clarity. Unfortunately, it looks like the Basic Fonts (Western) settings are set to default and correct. Any other ideas on how to reset the language preferences?

I've updated with a couple new images. I've tried removing the users ~/.config/libreoffice and that did not seem to help either...

kprice789 gravatar imagekprice789 ( 2019-08-14 00:16:58 +0200 )edit

Ifound a similar question on the site. In Tools>Options, Language Settings>Languages, try to change the UI language to French or Spanish even if you haven't installed the language pack. Restart. If it changes, re-set English UI, this may put things back in order.

ajlittoz gravatar imageajlittoz ( 2019-08-14 08:51:54 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-08-13 16:47:32 +0200

erAck gravatar image

Looks like the user has activated the Greek UI translation, take a look (best with your laptop aside) at what in the English UI would be menu Tools -> Options -> Language Settings -> Languages, User interface, and switch that back to Default (whatever) (unfortunately in Greek as well..). If nothing helps then with LibreOffice closed backup and move the user profile away, see https://wiki.documentfoundation.org/U... and start again.

Btw, LibreOffice 4.3.7.2 is pretty old ...

edit flag offensive delete link more

Comments

Thanks for the feedback! Unfortunately, neither step seems to help... The Languages seem to be set to Default English and moving the profile, with libreoffice closed did not reset the users language preferences. I've updated the post with new images for more detail.

I think you are on the right track though that it is still in English but in some sort of translation. Is there a different place to check this?

kprice789 gravatar imagekprice789 ( 2019-08-14 00:14:02 +0200 )edit

The strings look not translated, but rather transliterated from English (and only some of them - see dialog title)... how's that possible I wonder?

Mike Kaganski gravatar imageMike Kaganski ( 2019-08-14 10:07:58 +0200 )edit

Wrong or broken font used for UI maybe. Anything under Tools -> Options -> LibreOffice -> Fonts in the Replacement Table? Though even if that would be an ISO-8859-7 font it wouldn't explain that Latin characters are displayed as Cyrillic characters. Maybe reinstalling fonts on that machine helps.

erAck gravatar imageerAck ( 2019-08-14 13:25:01 +0200 )edit

(not Cyrillic, rather Greek ;-))

Maybe just that user fonts?

Mike Kaganski gravatar imageMike Kaganski ( 2019-08-14 13:36:54 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-08-12 23:01:42 +0200

Seen: 34 times

Last updated: Aug 14