How to reset LANG/Font

I have user that is having some Font or Language issue, not really sure what it is but it needs to get reset. Preferably from the CLI since the menus are difficult to navigate. Interestingly, no one else on this server seems to experience the same issue. So I feel like it’s something with the users home directory but not sure where this setting may be stored. It affects all of her LibreOffice applications, but not other applications. Has anyone seen this before?

Tools → Options → Language Settings → Languages
image description

Tools → Options → Libre Office Writer → Basic Fonts (Western)
image description

CentOS 6.10 2.6.32-754.9.1.el6.x86_64
LibreOffice Version:
Build ID:

Thank you!

Please edit your question to describe the symptoms. Your screenshot is not very legible. Is is a substitution? Looks like you have Greek letters but words are in English which suggests some symbols font is active. Have you tried Tools>Options, LibreOffice Writer>Basic Fonts (Western)?

I’ve updated the images with hopefully more clarity. Unfortunately, it looks like the Basic Fonts (Western) settings are set to default and correct. Any other ideas on how to reset the language preferences?

I’ve updated with a couple new images.
I’ve tried removing the users ~/.config/libreoffice and that did not seem to help either…

Ifound a similar question on the site. In Tools>Options, Language Settings>Languages, try to change the UI language to French or Spanish even if you haven’t installed the language pack. Restart. If it changes, re-set English UI, this may put things back in order.

I had the same issue. I posted this solution on another thread here, but since there’s two threads, I’ve added it here as well for convenience.

In my case, it ended up being a corrupted font. I’m using MacOs Mojave. To fix it, I restored the system fonts. Restore fonts that came with your Mac using Font Book - Apple Support
In the Font Book app on your Mac, choose File > Restore Standard Fonts.
Now I need to reinstall the fonts that were removed, but first I’ll verify them to make sure I don’t reinstall the corrupted font. Hope that helps.

The other question is: hi-my-computer-language-is-french-however-all-the-lo-menus-are-in-greek-but-not-real-greek-translation-of-each-french-letter-in-a-greek-letter-thanks-for-help/21491

(link added by ajlittoz)

Looks like the user has activated the Greek UI translation, take a look (best with your laptop aside) at what in the English UI would be menu Tools → Options → Language Settings → Languages, User interface, and switch that back to Default (whatever) (unfortunately in Greek as well…). If nothing helps then with LibreOffice closed backup and move the user profile away, see and start again.

Btw, LibreOffice is pretty old …

Thanks for the feedback! Unfortunately, neither step seems to help… The Languages seem to be set to Default English and moving the profile, with libreoffice closed did not reset the users language preferences. I’ve updated the post with new images for more detail.

I think you are on the right track though that it is still in English but in some sort of translation. Is there a different place to check this?

The strings look not translated, but rather transliterated from English (and only some of them - see dialog title)… how’s that possible I wonder?

Wrong or broken font used for UI maybe. Anything under Tools → Options → LibreOffice → Fonts in the Replacement Table? Though even if that would be an ISO-8859-7 font it wouldn’t explain that Latin characters are displayed as Cyrillic characters. Maybe reinstalling fonts on that machine helps.

(not Cyrillic, rather Greek ;-))

Maybe just that user fonts?