Ask Your Question
1

editing graphics created in MS Power Point [closed]

asked 2013-07-25 10:31:30 +0200

Ljiljan gravatar image

updated 2015-11-04 04:41:53 +0200

Alex Kemp gravatar image

I reported bug in LO bug page, but I wanted to see if you can confirmed this problem as well. Actually, it happens quite often when working with graphis created in MS Power Point...

https://bugs.freedesktop.org/show_bug.cgi?id=67293 (attachment/ PPTX presenentation is here)

When I open presentaton that is made in PPT(X), Impress open it perfectly good. I can save it in ODP, and reopen... everything is still great... but if I save it in PPT again (from new ODP), Power Point does not open it correctly.

Operating System: Ubuntu Version: 4.0.4.2 release

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-04 04:42:07.542539

3 Answers

Sort by » oldest newest most voted
2

answered 2013-07-25 14:12:39 +0200

oweng gravatar image

I can confirm this. Opening the PPTX attached to your bug in LO v4.0.4.2 under GNU/Linux and saving it as an ODF Presentation (ODP) appears to result in the file being saved correctly. Saving the PPTX in Microsoft PowerPoint 97/2000/XP/2003 (PPT) format results in loss of data from the second slide (the one with the AutoShape-based graphic) when opened using LO. Saving the ODP (the one created from the PPTX) in Microsoft PowerPoint 97/2000/XP/2003 (PPT) format results in the same loss of data as saving the PPTX directly to PPT (again, when opened using LO). The visual display in LO is:

slide screenshot

If either PPT (the one via PPTX or the one via PPTX -> ODP) is opened using PowerPoint 2011 Mac an error dialog is shown:

PowerPoint found a problem with content in the file file_name.ppt

PowerPoint can attempt to repair the file. If you trust the source of this file, click Repair.

Cancel | Repair

Clicking the Repair button does not appear to have any effect on improving the display over what is shown in LO.

While there are a lot of Impress PPT/X related bugs I had a look through the most obvious and there is nothing I could see that specifically relates to data loss with AutoShapes (images/graphics) during file save using the Microsoft PowerPoint 97/2000/XP/2003 (PPT) file format. Perhaps the closest is:

  • fdo#66248, PPTX export reuslts in corrupted according to PowerPoint2010

While it relates to the Microsoft PowerPoint 2007/2010 XML (PPTX) file format I would consider providing a reference in your bug due to the similarity. It is likely that LO v4.1 improves on the exporting to PPT as there have been numerous fixes.

edit flag offensive delete link more

Comments

See also fdo#66843

ROSt52 gravatar imageROSt52 ( 2013-07-26 03:05:21 +0200 )edit

@ROSt52, I think fdo#66843 is a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=61806 The callout example shape in that bug exhibits the exact same reversal of the pointer part. I will leave it for you to confirm this. There are currently a lot of presentation-related bugs that are duplicates. Hopefully the new v4.1 release will help us clear them up a bit.

oweng gravatar imageoweng ( 2013-07-26 04:22:17 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2013-07-25 10:31:30 +0200

Seen: 955 times

Last updated: Jul 25 '13