Ask Your Question
0

Text size changes after delete. Bug?

asked 2019-09-25 16:10:32 +0100

Aaron Digulla gravatar image

updated 2019-09-26 13:48:59 +0100

The default text style is "Text Body" using Liberation Serif, 10.5, LibreOffice 6.3.1.2, Ubuntu 18.04 When I type something, select a word and start typing again, suddenly all text to the end of the paragraph looks like it's only 5pt.

To reproduce: Type something, select the last character, type a letter. That new letter will be much smaller than the rest.

image description

What's more, the font size selector in the toolbar insists that it's 10.5pt text when it clearly isn't. Ctrl+M / "Clear Manual Formatting" fixes the bug.

Is this a known bug?

Demo document: C:\fakepath\font-size-bug.odt

edit retag flag offensive close merge delete

Comments

Cannot confirm on my Ubuntu 18.04 test system using LibreOffice 6.3.1.2 from launchpad PPA. Can you test using a fresh profile from command line:

LANG=en_US.UTF-8 libreoffice -env:UserInstallation=file:///tmp/LOTestUserProfile

Do you get the same behavior?

Opaque gravatar imageOpaque ( 2019-09-25 17:58:35 +0100 )edit

@Opaque Thanks for the feedback. It works with a fresh profile or when I just create a new document using my old profile. It's probably something in the document. I've attached a small demo document. Do you see the bug with it?

Aaron Digulla gravatar imageAaron Digulla ( 2019-09-26 13:49:47 +0100 )edit

And what is the role of the macro inside? Cannot confirm the behavior, but my macro security settings prevent the macro to run. Could it be that this macro causes your problem (there is a print ( text ))?.

Opaque gravatar imageOpaque ( 2019-09-26 14:07:23 +0100 )edit

I tried to delete the macro but seem to have failed. When I open the document, I disable the macro in the warning dialog -> it's not necessary and should not affect the result. Do you get the same behavior with the macro disabled/deleted?

Aaron Digulla gravatar imageAaron Digulla ( 2019-09-27 09:56:06 +0100 )edit

I newer run macros, whose purpose I don't understand. So it is deactivated as per security setting. And as stated in my comment above, the behavior you describe in your question is not shown.

Opaque gravatar imageOpaque ( 2019-09-27 14:08:59 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-10-04 09:12:59 +0100

Aaron Digulla gravatar image

I still have no idea what causes this behavior but I've found a fix/workaround: Create a new document, select everything and copy it to the new document.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-09-25 16:10:32 +0100

Seen: 39 times

Last updated: Oct 04