Ask Your Question
1

Error in asin-function? - "#NAME?"

asked 2019-09-30 12:51:25 +0100

Henrik-R gravatar image

The following formulae: =ASIN(0.5) Gives me this result: "#NAME?" I don't understand that. Both =ASIN(1) and =ASIN(0) works...

edit retag flag offensive close merge delete

Comments

Please provide LibreOffice Version, OS and to make it perfect - a sample file showing the problem.

Opaque gravatar imageOpaque ( 2019-09-30 13:04:23 +0100 )edit

Libreoffice:

Version: 6.0.7.3 Build ID: 1:6.0.7-0ubuntu0.18.04.10 CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; Locale: da-DK (en_US.UTF-8); Calc: group

OS: Ubuntu 18.04.3 LTS GNOME: 3.28.2

How do I upload an .ODS-file?

Henrik-R gravatar imageHenrik-R ( 2019-09-30 13:10:31 +0100 )edit

Use the clip symbol in edit.

Opaque gravatar imageOpaque ( 2019-09-30 13:11:44 +0100 )edit
1

what is your locale decimal separator? (I guess it's , not .)

Mike Kaganski gravatar imageMike Kaganski ( 2019-09-30 13:14:34 +0100 )edit

You're right!! That was the problem!...

Henrik-R gravatar imageHenrik-R ( 2019-09-30 13:20:20 +0100 )edit

Sorry - crosspost. But from my perspective #NAME? seems to be misleading and rather would expect a #VALUE! (I know that help mentions wrong decimal separator in explanation for 525)

Opaque gravatar imageOpaque ( 2019-09-30 13:20:59 +0100 )edit

The "Name" comes from LO thinking that a char sequence with that dot is some unrecognized name. It's not because it tried to convert it to a number and failed, but because it tried to find the name and filed.

Mike Kaganski gravatar imageMike Kaganski ( 2019-09-30 13:34:10 +0100 )edit

OK got the difference of =ASIN("test") and =ASIN(test)

Opaque gravatar imageOpaque ( 2019-09-30 13:38:13 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-09-30 13:20:31 +0100

Opaque gravatar image

updated 2019-09-30 13:21:39 +0100

Hello

your problem is a problem of locale da-DK and the delimiter in your formula. Danish decimal delimiter is the comma ,, while you used a dot.Change you formula to =ASIN(0,5) (or change Locale setting at Tools -> Options -> Language Settings -> Languages

Hope that helps.

edit flag offensive delete link more

Comments

Thank you! That was a dumb error...

Henrik-R gravatar imageHenrik-R ( 2019-09-30 13:22:37 +0100 )edit

Please, if the answer solves the question click ✔.

m.a.riosv gravatar imagem.a.riosv ( 2019-09-30 15:46:49 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-09-30 12:51:25 +0100

Seen: 21 times

Last updated: Sep 30