Error in asin-function? - "#NAME?"

The following formulae:
Gives me this result: “#NAME?”
I don’t understand that.
Both =ASIN(1) and =ASIN(0) works…

Please provide LibreOffice Version, OS and to make it perfect - a sample file showing the problem.


Build ID: 1:6.0.7-0ubuntu0.18.04.10
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: da-DK (en_US.UTF-8); Calc: group

OS: Ubuntu 18.04.3 LTS
GNOME: 3.28.2

How do I upload an .ODS-file?

Use the clip symbol in edit.

what is your locale decimal separator? (I guess it’s , not .)

You’re right!! That was the problem!..

Sorry - crosspost. But from my perspective #NAME? seems to be misleading and rather would expect a #VALUE! (I know that help mentions wrong decimal separator in explanation for 525)

The “Name” comes from LO thinking that a char sequence with that dot is some unrecognized name. It’s not because it tried to convert it to a number and failed, but because it tried to find the name and filed.

OK got the difference of =ASIN("test") and =ASIN(test)


your problem is a problem of locale da-DK and the delimiter in your formula. Danish decimal delimiter is the comma ,, while you used a dot.Change you formula to
=ASIN(0,5) (or change Locale setting at Tools -> Options -> Language Settings -> Languages

Hope that helps.

Thank you! That was a dumb error…

Please, if the answer solves the question click :heavy_check_mark:.