Ask Your Question
0

Libreoffice 6.3 Fails to start in Linux Mint 64

asked 2019-10-04 00:05:14 +0100

alanw gravatar image

Hi,

I downloaded Libreoffice 6.3 and ran dpkg on the deb folder. However, when starting with the command libreoffice6.3, nothing happens.

Here's the error message on the command line:

/opt/libreoffice6.3/program/soffice.bin: relocation error: /opt/libreoffice6.3/program/libvclplug_qt5lo.so: symbol _ZN5QIcon9fromThemeERK7QString, version Qt_5 not defined in file libQt5Gui.so.5 with link time reference

Your help is greatly appreciated.

edit retag flag offensive close merge delete

Comments

2

Does this work: export SAL_USE_VCLPLUGIN=gen; libreoffice6.3 ? And by the way - I assume 64 means 64-bit since latest Mint release is 19.2?

Opaque gravatar imageOpaque ( 2019-10-04 00:18:26 +0100 )edit

Yes, that worked!

Do I need to add the export directive to ~/.bashrc? or should I just add it to the command to start libreoffice?

And, yes, you are correct, I'm running Linux Mint 18, 64 bit.

Thanks!

alanw gravatar imagealanw ( 2019-10-04 01:55:49 +0100 )edit

I had the same problem in Ubuntu 12.04. export SAL_USE_VCLPLUGIN=gen; libreoffice6.3 worked to me also. Thanks

nagyt234 gravatar imagenagyt234 ( 2019-10-04 09:49:45 +0100 )edit

My comment was just a method to find out where your problem really is and thus I got the next question. Are you running Mint using KDE instead of standard Cinnamon desktop environment? If yes - and after the first test you've done, I'm pretty sure, that it's the case - you have a failing KDE installation. You ma also give: export SAL_USE_VCLPLUGIN=gtk3; libreoffice6.3 which will provide a better look&feel. If that also works, your KDE installation (which is using Qt5) is messed up a bit.

Opaque gravatar imageOpaque ( 2019-10-04 15:34:46 +0100 )edit

Thanks Opaque,

=gen actually gave me a very ugly interface. =gtk was much better and usable. =gtk3 and =gtk5 did not work at all.

You are right, my KDE is probably broke. I've used KDE for many years and probably played around with the system too much. I'm actually thinking of moving over to Manjaro Linux, KDE edition. I've heard really good things about Arch and this distro.

alanw gravatar imagealanw ( 2019-10-04 16:31:20 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-10-04 00:24:44 +0100

Ratslinger gravatar image

updated 2019-10-04 00:26:07 +0100

Hello,

Not certain as to which Linux Mint you have as there is no Mint 64.

Switched over to my Mint 19.2 Cinnamon with LO v6.3.2.2 installed from TDF.

Had no problem running libreoffice6.3 from terminal.

Installation was from the Deb folder in terminal and ran it as sudo dpkg -i *.deb. Have used this process for years on Ubuntu based systems without a problem.

edit flag offensive delete link more

Comments

1

Same here, no problem using your procedures, but OPs error message referencing to Qt5 makes my gut feeling that OP is using some KDE spin of Mint (or an own modification to use KDE).

Opaque gravatar imageOpaque ( 2019-10-04 00:42:47 +0100 )edit

Thanks. Didn't consider that.

Ratslinger gravatar imageRatslinger ( 2019-10-04 01:09:24 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-10-04 00:05:14 +0100

Seen: 102 times

Last updated: Oct 04