Libreoffice 6.3 Fails to start in Linux Mint 64


I downloaded Libreoffice 6.3 and ran dpkg on the deb folder. However, when starting with the command libreoffice6.3, nothing happens.

Here’s the error message on the command line:

/opt/libreoffice6.3/program/soffice.bin: relocation error: /opt/libreoffice6.3/program/ symbol _ZN5QIcon9fromThemeERK7QString, version Qt_5 not defined in file with link time reference

Your help is greatly appreciated.

Does this work: export SAL_USE_VCLPLUGIN=gen; libreoffice6.3 ? And by the way - I assume 64 means 64-bit since latest Mint release is 19.2?

Yes, that worked!

Do I need to add the export directive to ~/.bashrc? or should I just add it to the command to start libreoffice?

And, yes, you are correct, I’m running Linux Mint 18, 64 bit.


I had the same problem in Ubuntu 12.04. export SAL_USE_VCLPLUGIN=gen; libreoffice6.3 worked to me also. Thanks

My comment was just a method to find out where your problem really is and thus I got the next question. Are you running Mint using KDE instead of standard Cinnamon desktop environment? If yes - and after the first test you’ve done, I’m pretty sure, that it’s the case - you have a failing KDE installation. You ma also give: export SAL_USE_VCLPLUGIN=gtk3; libreoffice6.3 which will provide a better look&feel. If that also works, your KDE installation (which is using Qt5) is messed up a bit.

Thanks Opaque,

=gen actually gave me a very ugly interface. =gtk was much better and usable. =gtk3 and =gtk5 did not work at all.

You are right, my KDE is probably broke. I’ve used KDE for many years and probably played around with the system too much. I’m actually thinking of moving over to Manjaro Linux, KDE edition. I’ve heard really good things about Arch and this distro.


Not certain as to which Linux Mint you have as there is no Mint 64.

Switched over to my Mint 19.2 Cinnamon with LO v6.3.2.2 installed from TDF.

Had no problem running libreoffice6.3 from terminal.

Installation was from the Deb folder in terminal and ran it as sudo dpkg -i *.deb. Have used this process for years on Ubuntu based systems without a problem.

Same here, no problem using your procedures, but OPs error message referencing to Qt5 makes my gut feeling that OP is using some KDE spin of Mint (or an own modification to use KDE).

Thanks. Didn’t consider that.