Ask Your Question
0

Opening ODS file very slow. [closed]

asked 2013-08-11 17:44:33 +0100

ELadner gravatar image

updated 2015-08-30 00:17:34 +0100

Alex Kemp gravatar image

Windows 7, LO 4.1 (same behavior with 3.6 also).

Double clicking an ODS file on the desktop will eventually open, but it takes more than a minute (this is a small file we're talking about - maybe 12K on disk, about 20 or 30 cells with values).

Opening Calc first, then opening the file is relatively quick (less than one second).

I also tried saving as an XLSX file. Double-clicking the XLSX file is quick (< 1 second).

Has anyone else seen this behavior? Is it something messed up with the extension hangling or something?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-04 11:25:25.986973

4 Answers

Sort by » oldest newest most voted
1

answered 2015-08-19 01:16:40 +0100

Stunts gravatar image

This has been happening to me too on my linux system. It seems to be related to bug 79674. The workaround that seemed to work for me was to run libreoffice with:

SAL_DISABLE_SYNCHRONOUS_PRINTER_DETECTION="true" libreoffice /path/to/file.ods

I hope this is still interesting to anyone still following this question (Yes, I realize that it's been a while since this got asked).

edit flag offensive delete link more
0

answered 2014-07-26 16:54:23 +0100

I started having problems with LibreOffice opening very slowly until I cleared the list of recent documents (File --> Recent Documents --> Clear List), then it started opening very quickly again. This started happening after I had created a more complicated spreadsheet with charts. Was happening on both Windows 8.0 and 8.1 using LibreOffice 4.2.

edit flag offensive delete link more
0

answered 2014-09-25 16:42:54 +0100

I had a similar issue... Small ODF filesize (~350K) with about 3000 rows, and some calculations going on. Took about 10 minutes to open the file, and pegged CPU utilization of one core on my laptop at 100%. Even with some calculations, that's a LONG time to open a file. It eventually does open and seems to work fine... It's just the initial opening that seems troublesome. Here's the workaround I used... not a "fix" if you ask me however.

In Tools | Options, go to LibreOffice Calc | Formula and you will see options for "Recalculation on file load". For ODF Spreadsheet, I changed the selection to "Prompt User" and now my spreadsheet opens in less than 1 second.

This was using LibreOffice 4.0.4.2 on RHEL Workstation 6.5.

edit flag offensive delete link more
0

answered 2013-08-11 20:00:04 +0100

m.a.riosv gravatar image

Maybe this fixed bug is in relation: fdo#67099

edit flag offensive delete link more

Question Tools

3 followers

Stats

Asked: 2013-08-11 17:44:33 +0100

Seen: 3,970 times

Last updated: Sep 25 '14