Ask Your Question
0

Copy/Paste clipboard issues LibreOffice Calc

asked 2019-10-18 13:11:38 +0100

michaels2408 gravatar image

updated 2020-01-13 13:43:10 +0100

erAck gravatar image

So, i recently upgraded to 6.3.2.2 as the previous version was having the same issues and I was hoping for a fix. Ubuntu 19.10 desktop The copy past appears to be erratic. Sometimes when I select a square it copies it as a bitmap. Sometimes it copies it directly.. Sometimes it fails to copy and pastes the previous selection.

Thoughts? What am I doing wrong?

Thanks, Mike

edit retag flag offensive close merge delete

Comments

Please detail for every kind of copy the source (I guess 6.3) and destination.

m.a.riosv gravatar imagem.a.riosv ( 2019-10-18 16:02:58 +0100 )edit

Sounds like one of those clipboard destroyers (aka "manager") again.

erAck gravatar imageerAck ( 2019-10-18 16:49:20 +0100 )edit

I have a similar issue in Libreoffice Writer. I have to copy some text twice to paste it somewhere else.

ema261989 gravatar imageema261989 ( 2019-10-18 18:47:36 +0100 )edit

m.a.riosv So basically its random. Copying one cell to another in Calc. Sometimes it works, sometimes it doesn't. Its like the first copy I do sticks and instead of being text or a formula pastes a second time as a graphic.

michaels2408 gravatar imagemichaels2408 ( 2019-10-19 04:42:11 +0100 )edit

I think this has something to do with Ubuntu 19.10 because I am experiencing similar problems, but in other programs more often. LibreOffice: from time to time.

Ljiljan gravatar imageLjiljan ( 2019-11-10 10:26:13 +0100 )edit

I just upgraded to Pop!_OS 19.10 and have encountered this exact issue. I have to cut/copy once, then either undo the cut, or recopy the text a second time, and then it will show up as text instead of as a bitmap. I never had this problem on 19.04.

On top of this, when I try to undo the bitmap copy, LO crashes. Although its document recovery works, it doesn't recover the "cut" text that gets lost as a bitmap, so there is potential for significant data loss for the unsuspecting user if it happens to be a large cut/paste operation.

ayoungethan gravatar imageayoungethan ( 2019-11-11 08:32:38 +0100 )edit

I have the exact same problem with LO Version: 6.2.8.2 Still on Manjaro and Debian, both Gnome. Any one found a solution?

gngui gravatar imagegngui ( 2019-11-11 14:36:27 +0100 )edit

I'm seeing this too in LibreOffice Writer 6.3.2.2 on Ubuntu 19.10. The bug is annoying - I do lots of work in Writer and I copy and paste all the time, so this affects me a lot. I'd love to see it fixed.

medovina gravatar imagemedovina ( 2019-11-11 17:13:32 +0100 )edit

Note that Ubuntu 19.10 includes Mutter 3.34, which has a new clipboard manager:

https://www.phoronix.com/scan.php?pag...

It seems like that could be related.

medovina gravatar imagemedovina ( 2019-11-11 17:19:00 +0100 )edit

@Ljiljan, could you give an example of another app that's experiencing copy/paste issues on Ubuntu?

Marcus Tomlinson gravatar imageMarcus Tomlinson ( 2019-11-12 10:21:48 +0100 )edit

4 Answers

Sort by » oldest newest most voted
2

answered 2020-01-13 13:57:03 +0100

erAck gravatar image

updated 2020-03-16 12:30:56 +0100

So to summarize as answer not hidden in the comments, this appears to be a bug in the Mutter compositor's integrated clipboard manager, which is used in Ubuntu 19.04 and other distributions. See

Update 2020-03-16T12:30+01:00:

Citing from the mutter bug:

I can confirm the problem disappears in LibreOffice when I disable the Gnome Clipboard Indicator extension, and reappears when I re-enable the extension.

So disabling the Gnome Clipboard Indicator extension might help some.

edit flag offensive delete link more

Comments

FYI, I'll check Mutter, but the problem only occurs with Libreoffice apps,.

michaels2408 gravatar imagemichaels2408 ( 2020-01-13 18:54:18 +0100 )edit

Check the launchpad and mutter bugs and you'll see it's not only LibreOffice.

erAck gravatar imageerAck ( 2020-01-13 22:51:36 +0100 )edit

I do not have that extension and still I have the problem on LO... what I've been doing is to press Ctrl+C twice every time. The thing is that LO often pastes the previous selection. This problem also happens on other apps, but is much more frequent on LO.

rafaelhlima gravatar imagerafaelhlima ( 2020-05-13 17:16:20 +0100 )edit

I have the same problem in both 19.10 and 20.04 releases. for me too the only workaround is to do the copy action twice. If i need to "cut"... well, i don't. Copy + Copy then paste, then delete the part i needed to cut.

Carlos56 gravatar imageCarlos56 ( 2020-05-25 14:36:16 +0100 )edit
1

answered 2020-01-15 13:37:18 +0100

secondstriker gravatar image

I had the same issue. Mutter has problems with Xorg. But it works like a charm with Wayland. So if you have copy/paste issue with Libreoffice, you can log in to your ubuntu in Wayland.

edit flag offensive delete link more

Comments

Indeed, that's apparently why I don't encounter it (on Fedora F31) because I use a Wayland session.

erAck gravatar imageerAck ( 2020-02-12 16:49:47 +0100 )edit
0

answered 2020-05-24 21:24:37 +0100

I tried turning off clipboard managers, and nothing changed. However... When I use keybd commands (CTRL-INSERT) to copy, the paste operation works every time. Same results with Calc, and Writer.

edit flag offensive delete link more
0

answered 2020-06-24 13:10:06 +0100

lua gravatar image

Hi I have install wl-clipboard (available on Muon pack installer) and the problem is solved for me

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

6 followers

Stats

Asked: 2019-10-18 13:11:38 +0100

Seen: 4,226 times

Last updated: Jun 24