Ask Your Question
0

Saving as CSV - no warning [solved]

asked 2019-10-21 11:36:47 +0100

wdburgdorf gravatar image

updated 2019-10-21 13:59:41 +0100

Hi,

I just noticed that an original CSV file that I worked on for several hours last week, adding complex formulas and added sheets, I accidentally never saved as ODS. So my work is now lost.

When an original ODS is saved as CSV, there is a warning. But when a CSV is saved that has formulas or several sheets, there is none. I'd be surprised if I was the first person to have lost work that way.

Therefore I kindly ask the developers to add a warning when a CSV that has non-CSV features is saved.

Thank you.

edit retag flag offensive close merge delete

Comments

1

Hello,

besides the fact that development/enhancement requests should go to bugzilla, this seems not to be true - at least not true for all versions and/or all circumstances. Just opened a .csv file, added an additional sheet and clicked on Save button and got:

image description

Using

  Version: 6.3.2.2, Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
  CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde5;
  Locale: en-US (en_US.UTF-8); UI-Language: en-US, Calc: threaded

Just a hint/question: Could it be that this warning annoyed you sometime in the past and you unticked Tools -> Options -> Load / Save -> General -> [ ] Warn when not saving in ODF or default format?

Opaque gravatar imageOpaque ( 2019-10-21 11:42:15 +0100 )edit
1

And there are options to save the formulas in the sheet instead values, first time saving or 'saving as', editing filter settings.

m.a.riosv gravatar imagem.a.riosv ( 2019-10-21 12:01:20 +0100 )edit

@m.a.riosv Thanks, that's good to know. The issue was, though, that I never thought of checking optons (have used LO for years, first time this happened)

@Opaque I had version 6.06 installed, and thought, this had already been improved, meanwhile. So I installed the latest 6.2 and tried again - no warning!

Now I read your smallprint again and found the option you mentioned. I'm not sure I never unticked this. Must have been a very long time ago. So if this warning is on by default, and I switched it off myself, it's my own error. I will certainly not switch it off again. Thanks!

wdburgdorf gravatar imagewdburgdorf ( 2019-10-21 13:57:20 +0100 )edit

@wdburgdorf - did not test, but it may be also sufficient, if you unticked the option once in the past while saving a file and being warned (see the option in the warning message).

Opaque gravatar imageOpaque ( 2019-10-21 14:04:30 +0100 )edit

@Opaque This seems likely to have happened. Takes half a second and is quickly forgotten ...

wdburgdorf gravatar imagewdburgdorf ( 2019-10-21 14:12:11 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-10-21 13:58:52 +0100

wdburgdorf gravatar image

Answer by Opaque:

Could it be that this warning annoyed you sometime in the past and you unticked

Tools -> Options -> Load / Save -> General -> [ ] Warn when not saving in ODF or default format

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-10-21 11:36:47 +0100

Seen: 40 times

Last updated: Oct 21