Ask Your Question
0

LO Catalina file save / open dialog box not correct

asked 2019-11-21 04:15:31 +0200

JimM gravatar image

updated 2019-11-21 06:38:27 +0200

keme gravatar image

Mac OS: 10.15.1 (Catalina) LO: Version: 6.3.2.2 Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c CPU threads: 4; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; Locale: en-US (en_US.UTF-8); UI-Language: en-US

Screenshot of dialog box: Calc: threadedC:\fakepath\Screen Shot 2019-11-21 at 10.39.25 AM.png

After recently installing 1. MAC OS 10.15.1 (Catalina) and 2. LO 6.3.2.2, the LO open / save file dialog box changed to the one depicted in the attached screen shot. This box appears when using Calc, Draw, and Writer. I have not used Impress.

This particular dialog box is entirely new to me. It is most difficult to navigate. Further, it does not mirror or replicate the MAC OS file structure LO has here-to-fore displayed when performing file open / save tasks.

The question I have is this: Does the screen shot faithfully produce a (new) LO file open / save dialog box or is it possible that I have downloaded an unwanted extension or utility that is replacing the proper LO function? The advice I seek is two-fold. 1. If this dialog box is a new LO standard, does documentation exist that explains how to use it? 2. If this replacement is not native to LO, is it possible to de-activate it and return to the existing LO standard? How shall I accomplish this? Thank you.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-11-21 09:47:20 +0200

robleyd gravatar image

There are two options for Save dialogs in LO (for most OSes), the native dialog provided by the OS and the LibreOffice dialog; I'm not familiar with MacOS so I can't say which one you are using.

However, you can change this: go to Options | Preferences | LibreOffice | Advanced and click on the Open Expert Configuration button at the lower right of the dialog box. Use the search field at the top to search usesystemfiledialog. The search results will include, under org.openoffice.Office.Common/Misc, an item UseSystemFileDialog. Toggle the setting for that and see if you get what you want.

That setting used to be available easily under Options | Preferences | LibreOffice | general; why it has been shifted to where it is shall be a mystery forever.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. That will help other people with the same question.

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

edit flag offensive delete link more

Comments

robleyd,

I shall not repeat my first comment thanking Opaque for advice you also provided except to note that your parallel advice also is correct.

Thank you. Jim Martin

JimM gravatar imageJimM ( 2019-11-24 09:01:18 +0200 )edit
0

answered 2019-11-21 18:11:03 +0200

Opaque gravatar image

updated 2019-11-21 18:15:30 +0200

Hello,

Answer related to: Does the screen shot faithfully produce a (new) LO file open / save dialog box or is it possible that I have downloaded an unwanted extension or utility that is replacing the proper LO function?

You got a correct release of LibreOffice and this is not part of any extension. This dialog is part of LibreOffice and your screenshot shows the Open/Save dialog provided by LibreOffice and not the one provided by macOS.

Answer related to: If this dialog box is a new LO standard

This dialog is not a new standard but an option (to use) within LibreOffice and has been there since a very, very long time.

Answer related to If this replacement is not native to LO

This replacement is native to LibreOffice but not the default setting. You definitely have set LibreOffice -> Preferences -> LibreOffiice -> General -> Catgory: Open/Save Dialogs -> Option [x] Use LibreOffice Dialogs somehow manually - To revert to the file picker dialog provided by macOS untick the option.

My guess: May be you made this setting since there are advice around to circumvent some LibreOffice <-> Catalina problems (Save problems) by setting to use LibreOffice dialogs.

Hope that helps.

edit flag offensive delete link more

Comments

Opaque, Thank you. The information you provided is correct. The Options -> LibreOffice -> General -> Open/Save Dialogs box was checked. Unless other users report a similar confusion, I conclude that an action I took caused a change from not checked to checked. Although the meaning of "Use LibreOffice Dialogs" clearly means selecting/deselecting the option, the consequence is not clear. I was not able to locate an image of the native LibreOffice dialog in the Getting Started 60 user guide. I suggest that future editions of the guide incorporate the LO dialog popupin the options / preferences panel. I suggest also that instructions regarding navigating the native dialog be in the Getting Started guide. Thank you once again for your able help. Jim Martin

JimM gravatar imageJimM ( 2019-11-24 08:58:58 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-11-21 04:15:31 +0200

Seen: 468 times

Last updated: Nov 21 '19