Ask Your Question
0

Unable to Undo 'Wrap through background'

asked 2019-11-21 10:58:20 +0200

Pranav Bbhattarai gravatar image

updated 2020-07-15 21:20:59 +0200

ajlittoz gravatar image

I am unable to undo what I did. Solving C++ question in  Writer

This coding part in written inside the "text box". I was testing different wrap through option, but then stuck it one option which says 'Wrap in background'. Pressing Ctrl + Z doesn't reverse the situation which I found a little bit weird.

Any help is highly appreciated.

edit retag flag offensive close merge delete

Comments

I suppose this a Writer question, thus retag to erase common and replace with writer. While you're at it, edit both the title to spell "Wrap" instead of "warp". Warp has quite a different meaning!

ajlittoz gravatar imageajlittoz ( 2020-07-15 20:33:51 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2020-07-15 20:46:24 +0200

ajlittoz gravatar image

First, avoid using text boxes to insert sophisticated formatted text. Text boxes are drawing objects which do not interact well with the main text flow of the document. Text boxes are rather limited in their formatting flexibility. They are great for adding short labels to graphics but not for an elaborate text such as the one you exhibit.

Prefer frames when you have a "secondary flow" (a sequence of paragraphs with complex formatting where paragraph and character styles come in handy, what you can't do in text boxes.

Now, your problem.

When you gave your text box wrap attribute In Background, your text box was sent (warped ;-)) to the background, one layer behind text. It was removed from the constraints of text flow and ordinary text could then be typeset over it. After that, it is nearly impossible to click on some non transparent element of the text box because of the overlaying text.

Use the navigator, Drawing objects section, and double click on the text box object (it has a name like Shapen where n is a number) to select it. You can now Format>Wrap>any wrap option.

If you realise that In background was an error, you can Ctrl+Z to undo Apply attributes (this is what is shown in the Edit menu) provided you have not too many actions after the error. In which case you must undo these first.

Ctrl+Z from the keyboard works also here with LO 6.4.5.2 under Fedora 32, Plasma desktop.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

edit flag offensive delete link more
1

answered 2020-07-15 19:52:20 +0200

LeroyG gravatar image

File a bug. Same in LibreOffice 6.3.6.2 (x86); OS: Windows 6.1.

Meanwhile there could be a few workarounds, but think this one will work ever:

  • choose menu View - Toolbars - Drawing
  • select the Select tool (an arrow)
  • drag from within the page borders enclosing the text box
  • choose menu Format - Wrap and unselect In Background
  • could choose menu View - Toolbars and unselect Drawing

Also, if do you have another object in the document, select it, and with tab key you would reach the backgrounded box.

Check the mark (Correct answer mark) to the left of the answer that solves your question.

edit flag offensive delete link more

Comments

I think that there are many of us that should use the Navigator (F5) more.

LeroyG gravatar imageLeroyG ( 2020-07-16 12:31:54 +0200 )edit

Sorry but I DO NOT remember this. (I have a terrible memory). Anyway, thanks for reaching out and commenting. I will keep that in mind. @LeroyG

Pranav Bbhattarai gravatar imagePranav Bbhattarai ( 2020-07-17 08:18:06 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-11-21 10:58:20 +0200

Seen: 37 times

Last updated: Jul 15