Ask Your Question
0

No Connection to HSQLDB Embedded Database

asked 2019-11-27 11:15:59 +0100

Diagra gravatar image

updated 2019-11-27 11:28:38 +0100

Opaque gravatar image

I am a new user and want to start a database.

The connection to the external data source could not be established. No SDBC driver was found for the URL 'sdbc:embedded:hsqldb'. I get this when I try to open a new database. What does it mean?

Edit [Opaque] Made title a summary and put old title's text to details.

edit retag flag offensive close merge delete

Comments

1
Opaque gravatar imageOpaque ( 2019-11-27 11:24:46 +0100 )edit

If this is a Linux (Ubuntu-based) system, don't forget to install the required JDBC driver package as well.

Alex Thurgood gravatar imageAlex Thurgood ( 2019-11-27 11:38:54 +0100 )edit

My system is Mac OS 10.15.4. So, I'll try to install the required JDBC driver package.

Basin gravatar imageBasin ( 2020-05-29 17:40:51 +0100 )edit

@Basin - If you are on macOS - you probably missed to install JDK (and not JRE, which is not sufficient on macOS).

Opaque gravatar imageOpaque ( 2020-05-29 17:54:56 +0100 )edit

I installed JDK as the article "How to Install Java JRE/JDK" described above. But still get the same error.

Basin gravatar imageBasin ( 2020-06-01 19:05:29 +0100 )edit

I have no problem finding and running an existing database that I've created with, for example, Microsoft Access. I was trying to create a New Database from Base.

I use Actual Technologies for an ODBC driver. http://www.actualtech.com

They also have other drivers as well for Access Open Source Databases Oracle SQL Server.

Would one of these work with Base? I have contacted them but have not yet heard back from them.

Basin gravatar imageBasin ( 2020-06-01 19:08:55 +0100 )edit

installed JDK as the article "How to Install Java JRE/JDK" described above.

  • Downloaded from where (please provide exakt filename and URL)?
  • Did you activate (and check) LibreOffice -> Preferences -> LibreOffice -> Adavanced -> Option: [x] Use a Java runtime environment ?
Opaque gravatar imageOpaque ( 2020-06-02 12:42:59 +0100 )edit
1

@Basin : Let me guess, are you using LibreOffice Vanilla from the AppStore ? If so, then you won't be able to create any embedded hsqldb ODB files, as all Java functionality is deactivated with the LOVanilla app available from the AppStore. It won't make any difference whether you have installed a JDK or not, the code is simply non-functional with that particular version of LO. Either create an embedded Firebird database (you need to activate the experimental options under LO Preferences), or alternatively, remove LOVanilla and download and install LO from the TDF download website, then activate recognition and selection of the JDK from within LO > Preferences > Advanced. Re the Actual Technologies Driver, yes, you should be able to setup an ODBC connection using that driver, but it still requires you to have a database source backend, as ODBC is just the technology allowing you to access ...(more)

Alex Thurgood gravatar imageAlex Thurgood ( 2020-06-02 12:58:37 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2020-01-16 04:42:31 +0100

lgutierrezc gravatar image

This error is due to the fact that LibreOffice Base is not running in a Java environment, to do this, you access tools, options and in advanced, enable the checkbox: use a Java runtime environment, the environments you have appear in the box installed on your machine, click on apply and accept; Base and perfect reboots

edit flag offensive delete link more

Comments

When I tried to go to tools there is not an options menu item. Only Tools>Customize and there is not an advanced option there.

Basin gravatar imageBasin ( 2020-06-01 17:53:09 +0100 )edit

@Basin - people here are used to Tools -> Options since most of 'em use Linux or Windows. Whenever you see anybody using this path translate to LibreOffice -> Preferences, if you are on macOS.

Opaque gravatar imageOpaque ( 2020-06-02 12:45:17 +0100 )edit
0

answered 2020-05-24 00:16:58 +0100

On linux, make sure this package is installed, it doesn't seem to be automatic: libreoffice-sdbc-hsqldb.

edit flag offensive delete link more

Comments

I have a mac os 10.15.4

I went to Java to download but it said would not work with this updated version

Basin gravatar imageBasin ( 2020-06-01 17:54:41 +0100 )edit

I am on windows 10 64 bits with LO 64 bits and have the same problem. I have two jre installed, when I choose to use jre 10, LO says it is defective, however when choose jre 8 it is then accepted for use!

libre officer gravatar imagelibre officer ( 2020-06-07 18:45:49 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-11-27 11:15:59 +0100

Seen: 299 times

Last updated: May 24