Ask Your Question
1

Title Installing Jaybird on Windows and connecting LibreOffice to Firebird Server using JDBC

asked 2020-01-13 16:14:00 +0100

nexturejohn gravatar image

updated 2020-01-13 19:27:59 +0100

Hi, nothing seems simple when doing it the first time! I have managed to successfully install a Firebird 3.0 server on a Windows 7 machine, connect to it, and, using isql or FlameRobin, created and filled tables etc. So far so good.

Next step: connecting to the Firebird server from LibreOffice 6.2. Various posts and indications from Ratslinger point to using the Jaybird JDBC to enable this.

So I downloaded Jaybird 3.0.8-JDK_1.8.zip, unzipped it and located the jaybird-full-3.0.8.jar file, and pointed to it in LibreOffice in Class Path.

Then I went into the Base Database Wizard, and selected "Connect to an existing database", using the .fdb file I had set up previously in FlameRobin.

I selected the option "JDBC", and then followed Ratslinger's instructions: Datasource URL set: jdbc:firebirdsql:oo://localhost//c:/d/libre/firstdb.odb JDBC driver class: org.firebirdsql.jdbc.FBDriver

Tested the class and all ok. image description

Then moved onto specifying username and password, tested the connection, but got the error message that wire encryption was required. image description

Where do I set this in LibreOffice?

EDIT: answer my own question: in firebird.conf, I set WireCrypt = Enabled

Now a different error, it can't find the database, so I presume it is in the pathname I have specified. image description

Any suggestions? Thanks!

edit retag flag offensive close merge delete

Comments

Please delete all duplicates of this question. Thanks in advance …

Opaque gravatar imageOpaque ( 2020-01-13 17:02:52 +0100 )edit

@nexturejohn,

This is somewhat what I had eluded to in the comment in your last post.

This is now the third different question for this post:

  • JDBC connector install

  • unencrypted wire connection error

  • unavailable database

The last two are in the question the first deleted. This makes it difficult for people to answer. Each time I was about to answer, the question changed. Don't know if this is going to change again.

Ratslinger gravatar imageRatslinger ( 2020-01-13 22:27:05 +0100 )edit

if you can help with this last one, that would be great!

nexturejohn gravatar imagenexturejohn ( 2020-01-13 22:41:14 +0100 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2020-01-14 00:49:19 +0100

Ratslinger gravatar image

Hello,

I haven't used Windows in some time but it appears the for the DB location the / should be \:

firebirdsql:oo://localhost//c:\d\libre\firstdb.odb
edit flag offensive delete link more

Comments

thanks, you are right, the backslash is needed for the path name, but still gives a connection error unless the forward slashes around localhost are also removed. I also had to add the character set. Final solution for Windows:

datasource URL: jdbc: firebirdsql:oo:localhost:c:\d\libre\FIRSTDB.FDB?charSet=UTF-8
JDBC driver class: org.firebirdsql.jdbc.FBDriver

Thanks again for all the support and assistance. (Now that it connects on Windows, I will now move to get the Firebird Server working on the Lubuntu machine).

nexturejohn gravatar imagenexturejohn ( 2020-01-14 09:46:06 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-01-13 16:14:00 +0100

Seen: 48 times

Last updated: Jan 14