Ask Your Question
1

How do I import a csv file into Calc with European Characters [closed]

asked 2013-09-11 22:48:57 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I'm trying to import a csv file into LO Calc which has characters from a number of European languages however when I import it using the standard import options these special characters such as the German ß, etc are not displayed and instead there is a black triangle in it.

The import options being used are Character Set: Unicode (UTF-8) and Language Default - English (UK). I thought of changing the language however the file contains characters from several different languages (German, Norweigan, Greek off the top of my head) so not sure what I could choose.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-08 05:32:26.484848

Comments

Is the file an old DOS-file? If it is try to use one of the DOS Character sets.

horst gravatar imagehorst ( 2013-09-11 23:27:00 +0100 )edit

OP: @ktz84

manj_k gravatar imagemanj_k ( 2013-11-05 22:54:37 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-09-11 23:20:32 +0100

carnendil gravatar image

updated 2013-09-11 23:27:39 +0100

  1. [Ctrl] + [O].

  2. Navigate to your folder and select the .csv. Click the button "Open".

    Open <code>.csv</code> file

    Click to open a full-resolution image.

  3. Select the character encoding of interest from the drop-down list, and check on the bottom of the dialog box whether the characters show correctly. Select another encoding if the characters do not correspond. In the example below, I can see correctly the degree (°) character. In your case, it might be that the character encoding is not UTF-8.

    Select character encoding

    Click to open a full-resolution image.

  4. Select the type of separation and other options and click the button "Accept".

edit flag offensive delete link more

Comments

1

Thanks that worked.

ktz84 gravatar imagektz84 ( 2013-09-11 23:31:02 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2013-09-11 22:48:57 +0100

Seen: 2,928 times

Last updated: Sep 11 '13