How do I import a csv file into Calc with European Characters

I’m trying to import a csv file into LO Calc which has characters from a number of European languages however when I import it using the standard import options these special characters such as the German ß, etc are not displayed and instead there is a black triangle in it.

The import options being used are Character Set: Unicode (UTF-8) and Language Default - English (UK). I thought of changing the language however the file contains characters from several different languages (German, Norweigan, Greek off the top of my head) so not sure what I could choose.

Is the file an old DOS-file? If it is try to use one of the DOS Character sets.

OP: @ktz84

  1. [Ctrl] + [O].

  2. Navigate to your folder and select the .csv. Click the button “Open”.

    Click to open a full-resolution image.

  3. Select the character encoding of interest from the drop-down list, and check on the bottom of the dialog box whether the characters show correctly. Select another encoding if the characters do not correspond. In the example below, I can see correctly the degree (°) character. In your case, it might be that the character encoding is not UTF-8.

    Click to open a full-resolution image.

  4. Select the type of separation and other options and click the button “Accept”.

Thanks that worked.