Ask Your Question
0

LO Writer Paste function (Ctrl v) doesn't seem to work properly?

asked 2020-01-26 23:31:32 +0200

GaXve gravatar image

I'm not sure if I've checked an option somewhere that produces this result, if this is a bug in LO Writer, or if this is the intended function of LO Writer.

image description

Does anyone have any input on this?

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2020-01-26 23:37:43 +0200

tedtorres505 gravatar image

i got it to work using EDIT - Paste Special - Select HTML.

i think this selection includes the formatting.

edit flag offensive delete link more

Comments

This did not work for me. The unformatted text still takes on the formatting of the paste location.

GaXve gravatar imageGaXve ( 2020-02-10 07:48:04 +0200 )edit
0

answered 2020-01-26 23:52:58 +0200

keme gravatar image

updated 2020-01-27 00:08:43 +0200

This is intended behavior, I am sure. I assume that this happens when you copy text from Writer to Writer.

Any character formatting which has been applied (by text style or direct formatting) to the text you copy, will carry over to the target. Formatting based on paragraph style (i.e. not explicitly applied to the text you copied) does not carry over to the target.

In other words: Target paragraph style also applies to new text pasted when that text does not carry explicit formatting.

When you copy from other applications which do not use a compatible system of styles, the formatting should carry over in most cases.

Try the suggestion in this document where some words have been explicitly formatted to the same settings as the style already applies. The suggested copy/paste operation may be revealing...

edit flag offensive delete link more

Comments

"text does not carry explicit formatting." Gotcha! Thank you for this... Although I don't know how I feel about it. I don't know if it makes sense to me yet or not...

GaXve gravatar imageGaXve ( 2020-02-07 01:50:57 +0200 )edit

Actually, I don't think it should work this way. There is already the "Paste Unformatted Text" function. I think that when you perform a regular Paste (Ctrl + v), the text should retain it's "Non-Format" format, regardless of where it is pasted.

GaXve gravatar imageGaXve ( 2020-02-10 04:55:22 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2020-01-26 23:31:32 +0200

Seen: 48 times

Last updated: Jan 27