Ask Your Question
0

How to copy and paste a number data with comma in a cell? [closed]

asked 2013-09-30 13:58:33 +0200

lanieb gravatar image

updated 2015-11-10 07:03:27 +0200

Alex Kemp gravatar image

I am trying to paste some data to a specific Calc cells in a column, but upon pasting the data, it automatically formatted or outputted by a function of which I don't know what.

It's like this, I am trying to paste this data below:

437,438,438,439,440,441,442,443,444

outputted as; 437438438439441000000000

I wanted it just as what I've pasted. Numbers with comma and without any spaces.

I am using V3.5.2

UPDATE:

I forgot to mention that this spreadsheet shall be imported to a database.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-10 07:03:37.979028

2 Answers

Sort by » oldest newest most voted
0

answered 2013-09-30 14:13:10 +0200

JohnSUN gravatar image

Try this: F2 (edit cell) and then Ctrl+V (paste)

If after Enter you have same result (very long number without commas) just insert ' (apostrophe) before Ctrl+V

edit flag offensive delete link more

Comments

Superb! Very quick answer. The "apostrophe" did the trick. But how about pasting multiple row/cell at once? Do I have to create a separate question for this?

lanieb gravatar imagelanieb ( 2013-09-30 14:22:18 +0200 )edit

Try format target column as text (select it, press Ctrl+1 and choose "Text" in "Category") BEFORE pasting data

JohnSUN gravatar imageJohnSUN ( 2013-09-30 17:03:46 +0200 )edit

@JohnSUN

I forget to mention that this spreadsheet shall be imported to a database. So it won't accept the file since when importing the file it sees the apostrophe and interpret it like this '123,456,789

lanieb gravatar imagelanieb ( 2013-10-01 07:39:02 +0200 )edit

Will be dragging data into the Base? Or will you export data to a file CSV? Or some other method? The apostrophe should not be a source of problems - it's just an escape character for the Calc's tables.

JohnSUN gravatar imageJohnSUN ( 2013-10-01 13:29:29 +0200 )edit
0

answered 2013-09-30 17:15:16 +0200

Chansit gravatar image

For multiple row/column, Select cell that you want to paste data and then pasting your data with paste Special, selection -> Unformatted Text In Text import window (Fields), Select column data and change Column type to Text (Click Ok)

edit flag offensive delete link more

Comments

This method will work when you have data >1

Chansit gravatar imageChansit ( 2013-09-30 17:18:02 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2013-09-30 13:58:33 +0200

Seen: 4,303 times

Last updated: Oct 01 '13