Ask Your Question
0

Writer Automatic Capitalization Problems [closed]

asked 2013-10-01 05:43:36 +0200

championcake gravatar image

I know you can disable automatic capitalization for certain words, but I'm having a few specific problems with capitalization that are driving me crazy:

  1. When writing a scientific document, I often have to use the lower-case letter "i". I still want Writer to capitalize it, but is there a way to set writer to ignore the letter if I delete it and retype it? For instance, I would type the letter "i" and writer changes it to "I". I then hit backspace twice to delete it and type "i" again. This time it should ignore the "i" like it does in Word or other similar programs.
  2. I know you can disable auto correction or capitalization of certain words, but it seems I'm running into a problem where Writer is automatically making a letter lowercase that doesn't exist in the rules. For an example, I can't type the two capital letters P and K, followed by a subscript "a" without writer trying to make the capital K lowercase. I can't find a solution besides selecting the letter and making it uppercase explicitly. This takes a lot of time.

Any help would be greatly appreciated!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-10 07:05:17.123457

Comments

I have this almost exact problem which I posted in this forum. The letter "i" is before a "-" is always auto-capitalized. It does not happen with any other letter before a "-". Must be a bug, or a very stupid feature.

AlvinKho gravatar imageAlvinKho ( 2013-11-22 21:21:49 +0200 )edit
manj_k gravatar imagemanj_k ( 2013-11-22 23:09:33 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-10-01 10:34:31 +0200

oweng gravatar image

I am not sure you can change anything in the settings that will assist with Q1. You can however change your workflow to obtain what you require. After typing "i ", rather than pressing backspace twice, press left arrow and then backspace. Now when you type "i" it will remain at the beginning of the sentence. You can alter Tools > AutoCorrect Options... > Options tab > uncheck the "[M]" selection for the Capitalise first letter of every sentence option. This will prevent later alterations from changing any leading capital to an uppercase.

For Q2: Tools > AutoCorrect Options... > Exceptions tab > add "KPa" to the Words with TWo INitial CApitals list.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-10-01 05:43:36 +0200

Seen: 8,329 times

Last updated: Oct 01 '13