We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
3

Why did the icons disappear in the menus of version 6.4?

asked 2020-03-30 07:26:46 +0200

cosmiclaser gravatar image

updated 2021-06-14 21:54:35 +0200

Alex Kemp gravatar image

Have the icons been removed from the menus of version 6.4 (or 6.4.2)? Why ? Is there a way to put it back?

description de l'image

edit retag flag offensive close merge delete

Comments

They even removed the mnemonics (underlined letters) on Ubuntu-MATE 19.10 / LO 6.4.2 (I did the update yesterday and quite disappointed with that removal) I found some links which might help: https://ask.libreoffice.org/en/questi...https://bugs.documentfoundation.org/s...https://igurublog.wordpress.com/2014/... (none of them helped me, though)

ProLogic gravatar imageProLogic ( 2020-03-30 09:40:25 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2021-04-03 23:52:03 +0200

@DoctorRover : it somehow works but still not perfect on my Xubuntu box with LO 7.0.3. Some icons are still missing.

I've added the following line to the soffice script to get all the icons:

export SAL_USE_VCLPLUGIN=gen

Here is the comparison between VCL=gen (left) and VCL=gtk3 (right, with dark mode):

image description

edit flag offensive delete link more

Comments

Yes, right, the problem concerns gtk3 VCL plugin. It is default in GTK environments. This is why I mentioned them in the answer. As soon as you start LibreOffice with another VCL plugin, the problem is bypassed. In this situation, there is even the option in place to control the icons in the menus in the Options dialog.

So, the problem is that in LO 7.0.3+ the option is hidden in the Options dialog for gtk3 VCL plugin. The workaround I described allows redeeming access to this option through the expert configuration keeping use of the native VCL plugin.

DoctorRover gravatar imageDoctorRover ( 2021-04-04 12:14:51 +0200 )edit

Well, not really. In my answer, the right pic is per your answer and the left is per the use of the generic VCL plugin. You can notice 3 things:

  • Some icons on the left are missing on the right

  • The alignment of the text is not consistent on the right (the icon is considered as text)

  • There is a strange placeholder for some entries, with or without an icon.

Hagar Delest gravatar imageHagar Delest ( 2021-04-04 12:28:32 +0200 )edit

But these are different VCL plugins! Of course they look differently. The workaround in my answer allows activating the icons in gtk3 plugin.

Concerning absence of some of the icons, I have no idea why this happens.

DoctorRover gravatar imageDoctorRover ( 2021-04-04 12:34:59 +0200 )edit

Agreed. The use of the gtk3 plugin may better suit some users because it will use the windows manager theme (thus enabling a dark theme).

I just propose another alternative. It suits me better because they are more icons and better aligned. The drawback is that it can't use my dark theme.

Up to each user to decide what they prefer.

Hagar Delest gravatar imageHagar Delest ( 2021-04-04 12:40:28 +0200 )edit

Surely, having a choice is a good thing :)

As for the "strange placeholders for some entries", they are not strange and they are not placeholders. They are just checkboxes. Empty checkboxes without check marks. You can click them and they will be activated and marked by the check symbol.

Concerning the statement "the alignment of the text is not consistent on the right (the icon is considered as text)", it's not inconsistent. Such alignment allows having simultaneously the checkboxes and the icons in the menus. With the "gen" plugin, only either of them is displayed – either the checkbox or the icon. Invoke, for example, View menu and you will notice that you cannot identify if (again, for example) "Formatting Marks" is activated or not. This is because this item has an icon and, thus, the checkbox is hidden.

In regard to absence of some icons, those icons are not ...(more)

DoctorRover gravatar imageDoctorRover ( 2021-04-05 00:48:50 +0200 )edit

Sorry but I disagree here.

If they are check boxes, then they are unnecessary. Why a check box in front of Text Box and Hyperlink? Clicking them does absolutely nothing except invoking the dialog or creating the text box (expected action). And it doesn't stay checked afterward. I do know about true check boxes.

In the View menu for example, the generic plugin puts a light frame around the icons, no need to add an additional check box cluttering the menu. Why remove the icon when the menu is expandable with a submenu? The icon is a great help, preventing you from deciphering the text of the entries.

And again, sorry, but visually, not aligning the text entries with the same indent is much less comfortable to skim the menu when looking for an entry.

image description

Hagar Delest gravatar imageHagar Delest ( 2021-04-05 10:29:07 +0200 )edit
2

answered 2021-04-03 18:54:45 +0200

DoctorRover gravatar image

updated 2021-04-03 18:58:38 +0200

This is a bug. It concerns all GTK environments – GNOME Shell, XFCE, MATE, Cinnamon… The bug has been fixed in LibreOffice starting from version 7.0.3. Unfortunately, the option to control visibility of the icons in the menus was axed from the regular Options dialog. Still, it remains accessible through the Expert Configuration. To turn on the icons, do the following steps:

1) Go to Options – LibreOffice – Advanced – press the button “Open Expert Configuration”.

2) Search the string “IconsInMenu”. Set the two found boolean parameters to the following values:

ShowIconsInMenues --> true

IsSystemIconsInMenus --> false

3) Restart LibreOffice.

edit flag offensive delete link more
0

answered 2020-03-30 10:50:28 +0200

ebot gravatar image

Try the safe mode.

If the error remains not constant, reset your user profile.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-03-30 07:26:46 +0200

Seen: 424 times

Last updated: Apr 03