Dark themes broken - Linux + LibreOffice writer version

Hello! I updated LibreOffice and on next launch, I wasn’t in darkmode any longer.

I have:

  • Navigated to options → view - > tried several themes.
    Note: Dark themes apply but the dark background doesn’t, causing the icons to “disappear”
    Light themes still work.

  • Reinstalled the software through the Discover store

  • Started in safe mode and factory reset the software, checked both boxes

  • Tried multiple themes with “dark” in the name

  • Confirmed I do not have experimental options enabled

  • Tried selecting “Automatically detect high contrast mode of operating system” which had the same end result as selecting a dark theme, namely, the background stayed light and the icons washed out against it.

It looks like it just… stopped applying the dark background for all of the dark themes.

I had to remove the section of resources referenced due to new user rules, but I searched through various recent asks related to dark mode and none of their answers seemed to assist with my concern.

I did also find this, but it says it was fixed as of 7.0.3 so it shouldn’t apply.

Under advanced, it does say I’m using JRE but the only listed, flathub 11.0.14, isn’t selected. I have no idea whether this is relevant but I did notice that the last article I linked mentioned the GTK environment so I figured it didn’t hurt to mention/specify.

Any other thoughts/suggestions? I’d really like to have my dark mode back on my steam deck please.

Your last sentence may be the most important one… Anything special on your distribution? Not everybody is faniliar with steam-decks. (And I just know what that is…).
But if it was after the last update for LibreOffice my suggestion would be to use the previous one, after giving a bug-report on bugzilla.

Yeah I don’t imagine many people bother using the software on a device designed for gaming so that doesn’t surprise me.

I’m not particularly familiar with linux so unfortunately, I don’t think I would recognize “anything unusual” if it were staring me in the face screaming like a drill seargent.

That said, you’re probably right. I’m not sure how to choose a specific iteration, can you do that through the discover store or would I need to remove it through the store, then go to the website and download a linux copy from there?

Used google a bit and found your steam deck seems to use a variant of arch linux with KDE.

But as flathub is installed your LibreOffice may be installed as a flatpack
My first try would be the discover store, if this is not working I would deinstall the current version and try the package-management. (Even considering my first encounter with pacman was not successful.)

Fair enough. Mind providing a bit more details on what you mean by package management?

I did confirm that it’s a flatpack as per the details on the discovery store, but the discovery store doesn’t seem to provide any options for downloading prior versions, only the current versions.

I also pulled up the website on my steamdeck and the only flatpack offering there, too, is the latest version.

You mentioned pacman, I’m assuming that’s a program of some sort for downloading specific versions of software, right? How would I go about using it for package management in this context?

Linux is using a clever system to avoid double-installs. If you already have a graphics-library or a postscript-toolkit in your system, wich is also needed for your new program then the new program can use the same stuff you already have. No need for double installation and the operating-system can even keep the components updated, without your program knowing.
So we need more information on the software we install and instead of older .tar or .bz, .zip -Archives “packages” with additional info were developed. You find apt for Debian, rpm on Red-Hat and pacman on Arch-Linux…


I found the latter using a common search engine with “use pacman on steam deck” and I recommend you to do the same.
One thing to remember: I read you may loose anything you installed during updates by Valve. So you would have to re-install LibreOffice after an update…
And always keep backups of YOUR files!
Actually I have no clue where valve changed the “typical” installation of Arch. So your path may not be easy…