We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

[Calc] Hyperlinks not clickable

asked 2020-04-11 11:23:21 +0200

Winfried gravatar image

updated 2020-04-11 11:24:03 +0200


I followed the instructions to turn text into URLs by…

  1. Selecting the column
  2. Replacing all cells with =HYPERLINK("&")

… but the text isn't actually turned into clickable URLs.

What's wrong?

Thank you.


edit retag flag offensive close merge delete


Tested your procedure and for me it works. Are you aware that you need to hold down CTRL key and click to get to the URL destination?

Tested using LibreOffice:

Version:; Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kf5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US; Calc: threaded
Opaque gravatar imageOpaque ( 2020-04-11 11:45:20 +0200 )edit

Related to your "Answer": 2 options now:

  1. Please upload a sample file showing your problem (Edit your question and use the clip symbol to upload a file - don't use Add Answer) and please mention your operating system version Windows xy ?

  2. Try to start your LibreOffice instance in LibreOffice Safe Mode (Help -> Restart in Safe Mode...) and perform your test once more. If it works in Safe Mode, you probably face one of these strange side effects of a corrupt LibreOffice user profile and you need to reset your user profile.

PS: If you see the formula as text, you may check View -> Show Formula, but this won't/shouldn't influence the CTRL+click behavior.

Opaque gravatar imageOpaque ( 2020-04-11 14:16:47 +0200 )edit

Oh my! Were the cells actually "formatted as Text (@)"? This would explain everything.
Fortunately you (@Opaque) looked a second time at the images. I wouldn't assume the user had changed the respective option under >View>>Display..

Lupp gravatar imageLupp ( 2020-04-11 15:05:03 +0200 )edit

If the usage of HYPERLINK() only was considered a workaround having missed automatic recognition of URL: Enable the respective Option under
>Tools>>AutoCorrect Options...>>Options>URL Recognition
The menu path is slightly different in Calc as compared with Writer.

Lupp gravatar imageLupp ( 2020-04-15 11:29:34 +0200 )edit

3 Answers

Sort by » oldest newest most voted

answered 2020-04-11 12:04:42 +0200

Lupp gravatar image

updated 2020-04-11 12:22:57 +0200

I couldn't find a clearly related bug report, but I also experienced a related issue. (I didn't report the bug myself.) It concerned some different cases of automatically creating a sequence of URL-as-text made working links with the help of the HYPERLINK() function.
However, it seems to be fixed with V 6.4.2 (at latest). My test also worked as the one by @Opaque did.

edit flag offensive delete link more


@Lupp - tried to find a bug report myself for earlier versions. Got the same bug search result like you.

Checked also LibreOffice and found it fixed in that release as well.

Opaque gravatar imageOpaque ( 2020-04-11 12:14:26 +0200 )edit

answered 2020-04-11 13:55:42 +0200

Winfried gravatar image

updated 2020-04-11 13:56:46 +0200

Thanks for the tip. I should have checked for a more recent release.

Updated to the latest and greatest (, reopened document: The links are still just text, and clicking/double-clicking even while holding the CTRL key does nothing.

Edited column to start from just the plain URLs, re-changed to add the =HYPERLINK sequence as shown in the original question: Still no clickable links, just text.

edit flag offensive delete link more


Please do not use Add Answer if you actually don't answer a question but commenting an answer. Please use add a comment for that purpose. Thanks in advance …

Opaque gravatar imageOpaque ( 2020-04-11 14:13:08 +0200 )edit

You should, of ourse, repeat the process using the recent version. The file you opened with the new version may be damaged in a hidden way, and not repaired on the fly when opened now,
If you get the same dysfunctional results with LibO 6.4.2 there must be a poblem with your local situation.
(Very strange effects are sometimes caused by user profile corruption.)

Lupp gravatar imageLupp ( 2020-04-11 14:57:00 +0200 )edit

answered 2021-01-07 19:40:57 +0200

wsanders gravatar image

A couple of times, when I have upgraded LIbreoffice, hyperlinks go dead. In one case I had to recreate all of them. It happened again just now upgrading to on Fedora, but, helpfully, I also see a popup hover tip that says "Ctrl-click to open hyperlink". So in this case I'll just accept this behavior and move on.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2020-04-11 11:23:21 +0200

Seen: 400 times

Last updated: Jan 07