[Calc] Hyperlinks not clickable


I followed the instructions to turn text into URLs by…

  1. Selecting the column
  2. Replacing all cells with =HYPERLINK("&")

… but the text isn’t actually turned into clickable URLs.

What’s wrong?

Thank you.


Tested your procedure and for me it works. Are you aware that you need to hold down CTRL key and click to get to the URL destination?

Tested using LibreOffice:

Version:; Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kf5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US; Calc: threaded

Related to your “Answer”: 2 options now:

  1. Please upload a sample file showing your problem (Edit your question and use the clip symbol to upload a file - don’t use Add Answer) and please mention your operating system version Windows xy ?

  2. Try to start your LibreOffice instance in LibreOffice Safe Mode (Help -> Restart in Safe Mode...) and perform your test once more. If it works in Safe Mode, you probably face one of these strange side effects of a corrupt LibreOffice user profile and you need to reset your user profile.

PS: If you see the formula as text, you may check View -> Show Formula, but this won’t/shouldn’t influence the CTRL+click behavior.

Oh my! Were the cells actually “formatted as Text (@)”? This would explain everything.
Fortunately you (@anon73440385) looked a second time at the images. I wouldn’t assume the user had changed the respective option under >View>>Display

If the usage of HYPERLINK() only was considered a workaround having missed automatic recognition of URL: Enable the respective Option under
>Tools>>AutoCorrect Options...>>Options>URL Recognition
The menu path is slightly different in Calc as compared with Writer.

I couldn’t find a clearly related bug report, but I also experienced a related issue. (I didn’t report the bug myself.) It concerned some different cases of automatically creating a sequence of URL-as-text made working links with the help of the HYPERLINK() function.
However, it seems to be fixed with V 6.4.2 (at latest). My test also worked as the one by @anon73440385 did.

@Lupp - tried to find a bug report myself for earlier versions. Got the same bug search result like you.

Checked also LibreOffice and found it fixed in that release as well.

Thanks for the tip. I should have checked for a more recent release.

Updated to the latest and greatest (, reopened document: The links are still just text, and clicking/double-clicking even while holding the CTRL key does nothing.

Edited column to start from just the plain URLs, re-changed to add the =HYPERLINK sequence as shown in the original question: Still no clickable links, just text.

Please do **not** use *Add Answer* if you actually don't answer a question but commenting an answer. Please use ***add a comment*** for that purpose. Thanks in advance …

You should, of ourse, repeat the process using the recent version. The file you opened with the new version may be damaged in a hidden way, and not repaired on the fly when opened now,
If you get the same dysfunctional results with LibO 6.4.2 there must be a poblem with your local situation.
(Very strange effects are sometimes caused by user profile corruption.)

A couple of times, when I have upgraded LIbreoffice, hyperlinks go dead. In one case I had to recreate all of them. It happened again just now upgrading to on Fedora, but, helpfully, I also see a popup hover tip that says “Ctrl-click to open hyperlink”. So in this case I’ll just accept this behavior and move on.